summaryrefslogtreecommitdiffstats
path: root/tools/quilt
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-02-24 20:19:32 -0800
committerPaul Spooren <mail@aparcar.org>2022-02-25 14:12:39 +0100
commit68a20d86313a58128cc8c17a58d5bd38c603c673 (patch)
treeacf637ffa8ebf1a27aef0619fe51a19558aff3e1 /tools/quilt
parentfb830fd894f7ae5ad23f712ebf50808f8be2a1f7 (diff)
downloadopenwrt-68a20d86313a58128cc8c17a58d5bd38c603c673.tar.gz
openwrt-68a20d86313a58128cc8c17a58d5bd38c603c673.tar.bz2
openwrt-68a20d86313a58128cc8c17a58d5bd38c603c673.zip
tools/quilt: update to 0.67
- Call pager with original LANG environment variable - Consistently complain early if no series file is found - Fix handling of symbolic links by several commands - Tighten the patch format parsing - Reuse the shell (performance) - Document the series file format further - Document that quilt loads /etc/quilt.quiltrc - configure: Make stat configurable - series: Minor optimizations - setup: Don't obey the settings of any englobing .pc - setup: Default to fast mode - quilt.el: Fix documentation of quilt-pc-directory - quilt.el: Load /etc/quilt.quiltrc if ~/.quiltrc doesn't exist - quilt.el: Fix quilt-editable when QUILT_PATCHES_PREFIX is set Refresh patches. Signed-off-by: Rosen Penev <rosenp@gmail.com> [add changelog] Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'tools/quilt')
-rw-r--r--tools/quilt/Makefile4
-rw-r--r--tools/quilt/patches/000-relocatable.patch4
-rw-r--r--tools/quilt/patches/001-fix_compile.patch2
3 files changed, 5 insertions, 5 deletions
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
index 149b7996a3..c16f989b5d 100644
--- a/tools/quilt/Makefile
+++ b/tools/quilt/Makefile
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=quilt
-PKG_VERSION:=0.66
+PKG_VERSION:=0.67
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/quilt
-PKG_HASH:=314b319a6feb13bf9d0f9ffa7ce6683b06919e734a41275087ea457cc9dc6e07
+PKG_HASH:=3be3be0987e72a6c364678bb827e3e1fcc10322b56bc5f02b576698f55013cc2
include $(INCLUDE_DIR)/host-build.mk
diff --git a/tools/quilt/patches/000-relocatable.patch b/tools/quilt/patches/000-relocatable.patch
index 666c4b4791..caf5eb89a6 100644
--- a/tools/quilt/patches/000-relocatable.patch
+++ b/tools/quilt/patches/000-relocatable.patch
@@ -92,7 +92,7 @@
SHELL:= @BASH@ # It does not work if dash is used as a shell, for example
GREP := @GREP@
TAIL := @TAIL@
-@@ -32,7 +32,7 @@ AWK := @AWK@
+@@ -33,7 +33,7 @@ AWK := @AWK@
FIND := @FIND@
XARGS := @XARGS@
DIFF := @DIFF@
@@ -101,7 +101,7 @@
MKTEMP := @MKTEMP@
MSGMERGE := @MSGMERGE@
MSGFMT := @MSGFMT@
-@@ -49,8 +49,8 @@ USE_NLS := @USE_NLS@
+@@ -50,8 +50,8 @@ USE_NLS := @USE_NLS@
STAT_HARDLINK := @STAT_HARDLINK@
PATCH_WRAPPER := @PATCH_WRAPPER@
diff --git a/tools/quilt/patches/001-fix_compile.patch b/tools/quilt/patches/001-fix_compile.patch
index 56e38728de..ef6f8ff608 100644
--- a/tools/quilt/patches/001-fix_compile.patch
+++ b/tools/quilt/patches/001-fix_compile.patch
@@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -275,13 +275,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
+@@ -276,13 +276,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
@$(if $(filter $@,$(NON_EXEC_IN)),,chmod +x $@)
configure : configure.ac aclocal.m4