summaryrefslogtreecommitdiffstats
path: root/tools/sparse
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-04-12 21:21:49 +0000
committerJohn Crispin <john@openwrt.org>2014-04-12 21:21:49 +0000
commit76133009c90284c6c0eab59207f01980a3222213 (patch)
tree3225ab99d9d57b5de3be77190f5a9ade3949ee0b /tools/sparse
parent72803e0e27ec149784ff22ee528a7c11c6eefed1 (diff)
downloadopenwrt-76133009c90284c6c0eab59207f01980a3222213.tar.gz
openwrt-76133009c90284c6c0eab59207f01980a3222213.tar.bz2
openwrt-76133009c90284c6c0eab59207f01980a3222213.zip
sparse: add as a new package selectable from the config
This change does multiple things, all related to enable sparse usage as a static analysis tool selectable from the OpenWrt configuration: *add a KERNEL_SPARSE option in the config to add sparse to the kernel build (through the C=1 option usage) *add sparse as a new host tools. It will get selected automatically when the above option will be enabled Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com> SVN-Revision: 40490
Diffstat (limited to 'tools/sparse')
-rw-r--r--tools/sparse/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/sparse/Makefile b/tools/sparse/Makefile
new file mode 100644
index 0000000000..6cdeed5cca
--- /dev/null
+++ b/tools/sparse/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2014 Qualcomm-Atheros Inc.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sparse
+PKG_VERSION:=0.5.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@KERNEL/software/devel/sparse/dist/
+PKG_MD5SUM:=68bc834c57836251fbee55a7707bab39
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/sparse $(STAGING_DIR_HOST)/bin
+endef
+
+$(eval $(call HostBuild))