summaryrefslogtreecommitdiffstats
path: root/tools/zstd
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-04-05 14:29:50 +0200
committerRobert Marko <robimarko@gmail.com>2024-04-06 11:24:18 +0200
commited149717eec3bfe42d4cc32ee1d74cc53a19bad5 (patch)
tree0f6e076a0d54f06f5ff83e23dfbe123acce30186 /tools/zstd
parent4b920e799fba445c450d9bc86843c0a37e202e7f (diff)
downloadopenwrt-ed149717eec3bfe42d4cc32ee1d74cc53a19bad5.tar.gz
openwrt-ed149717eec3bfe42d4cc32ee1d74cc53a19bad5.tar.bz2
openwrt-ed149717eec3bfe42d4cc32ee1d74cc53a19bad5.zip
tools: zstd: override max safe compression level
ZTSD limits the safe compression level to a max of 19 as 20 to 22 cause increased RAM usage. Higher levels require --ultra arg passed. There isn't currently a way to set --ultra using ENV options similar to ZSTD_CLEVEL and ZSTD_CLEVEL is limited to 19. To fix this, we can increase the max safe compression level by providing a custom ZSTDCLI_CLEVEL_MAX value with CFLAGS. The max safe level is increased to 20. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'tools/zstd')
-rw-r--r--tools/zstd/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/zstd/Makefile b/tools/zstd/Makefile
index 3f69c6d497..d194ecd005 100644
--- a/tools/zstd/Makefile
+++ b/tools/zstd/Makefile
@@ -17,6 +17,9 @@ include $(INCLUDE_DIR)/host-build.mk
HOSTCC:= $(HOSTCC_NOCACHE)
+HOST_CFLAGS += \
+ -DZSTDCLI_CLEVEL_MAX=20
+
HOST_MAKE_FLAGS += \
ZSTD_LEGACY_SUPPORT=7 \
BACKTRACE=0 \