summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-01 11:03:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-01 11:03:51 +0000
commit304c93e4871cb5e1fbf16921fa082ed4a1bb43c4 (patch)
tree5744837bd2cb0c148559ef3f5e36129069f78187 /tools
parentb2e997983bece1d213c12d5533613e29f274868b (diff)
downloadopenwrt-304c93e4871cb5e1fbf16921fa082ed4a1bb43c4.tar.gz
openwrt-304c93e4871cb5e1fbf16921fa082ed4a1bb43c4.tar.bz2
openwrt-304c93e4871cb5e1fbf16921fa082ed4a1bb43c4.zip
install a symlink to the correct version of find in $(STAGING_DIR_HOST)/bin
SVN-Revision: 12451
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 3cfbb8bbda..989f3f0975 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -26,8 +26,11 @@ $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
$(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
touch $@
-$(curdir)//prepare = $(STAGING_DIR)/.prepared
-$(curdir)//compile = $(STAGING_DIR)/.prepared
+$(STAGING_DIR_HOST)/bin/find:
+ [ -x "$(FIND)" ] && ln -sf "$(FIND)" $@
+
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
+$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
# prerequisites for the individual targets
$(curdir)/ := .config prereq