summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2024-01-24 13:26:31 +0100
committerNick Hainke <vincent@systemli.org>2024-01-25 16:07:42 +0100
commitae7a7ef5da250d59953f4365ce0ccf014dd89d14 (patch)
treec5e36d21b70865de4738f85ae440c38d19be1d6a /tools
parent6fbe36a618566fae2d12486c0aac2a81dc6c8c48 (diff)
downloadopenwrt-ae7a7ef5da250d59953f4365ce0ccf014dd89d14.tar.gz
openwrt-ae7a7ef5da250d59953f4365ce0ccf014dd89d14.tar.bz2
openwrt-ae7a7ef5da250d59953f4365ce0ccf014dd89d14.zip
tools/mkimage: update to 2024.01
Update to latest version. Refresh patch: - 030-allow-to-use-different-magic.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'tools')
-rw-r--r--tools/mkimage/Makefile4
-rw-r--r--tools/mkimage/patches/030-allow-to-use-different-magic.patch4
2 files changed, 4 insertions, 4 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 5dceb9a471..ae744f9bf3 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,14 +7,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2023.10
+PKG_VERSION:=2024.01
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
https://mirror.cyberbits.eu/u-boot \
https://ftp.denx.de/pub/u-boot \
ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=e00e6c6f014e046101739d08d06f328811cebcf5ae101348f409cbbd55ce6900
+PKG_HASH:=b99611f1ed237bf3541bdc8434b68c96a6e05967061f992443cb30aabebef5b3
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
diff --git a/tools/mkimage/patches/030-allow-to-use-different-magic.patch b/tools/mkimage/patches/030-allow-to-use-different-magic.patch
index 3689fcb531..f2f57965f6 100644
--- a/tools/mkimage/patches/030-allow-to-use-different-magic.patch
+++ b/tools/mkimage/patches/030-allow-to-use-different-magic.patch
@@ -50,7 +50,7 @@ This patch makes it possible to set a custom image magic.
break;
--- a/tools/default_image.c
+++ b/tools/default_image.c
-@@ -68,7 +68,7 @@ static int image_verify_header(unsigned
+@@ -67,7 +67,7 @@ static int image_verify_header(unsigned
*/
memcpy(hdr, ptr, sizeof(struct legacy_img_hdr));
@@ -59,7 +59,7 @@ This patch makes it possible to set a custom image magic.
debug("%s: Bad Magic Number: \"%s\" is no valid image\n",
params->cmdname, params->imagefile);
return -FDT_ERR_BADMAGIC;
-@@ -147,7 +147,7 @@ static void image_set_header(void *ptr,
+@@ -146,7 +146,7 @@ static void image_set_header(void *ptr,
}
/* Build new header */