summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/mvebu/image/cortexa9.mk24
1 files changed, 11 insertions, 13 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 7c68740e11..a73e3ff5e5 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -114,33 +114,31 @@ define Device/cznic_turris-omnia
endef
TARGET_DEVICES += cznic_turris-omnia
-define Device/fortinet_fg-30e
+define Device/fortinet
DEVICE_VENDOR := Fortinet
- DEVICE_MODEL := FortiGate 30E
SOC := armada-385
KERNEL := kernel-bin | append-dtb
- KERNEL_INITRAMFS := kernel-bin | append-dtb | fortigate-header | \
- gzip-filename FGT30E
KERNEL_SIZE := 6144k
- DEVICE_DTS := armada-385-fortinet-fg-30e
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
sysupgrade-tar rootfs=$$$$@ | append-metadata
DEVICE_PACKAGES := kmod-hwmon-nct7802
endef
+
+define Device/fortinet_fg-30e
+ $(Device/fortinet)
+ DEVICE_MODEL := FortiGate 30E
+ DEVICE_DTS := armada-385-fortinet-fg-30e
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | fortigate-header | \
+ gzip-filename FGT30E
+endef
TARGET_DEVICES += fortinet_fg-30e
define Device/fortinet_fg-50e
- DEVICE_VENDOR := Fortinet
+ $(Device/fortinet)
DEVICE_MODEL := FortiGate 50E
- SOC := armada-385
- KERNEL := kernel-bin | append-dtb
+ DEVICE_DTS := armada-385-fortinet-fg-50e
KERNEL_INITRAMFS := kernel-bin | append-dtb | fortigate-header | \
gzip-filename FGT50E
- KERNEL_SIZE := 6144k
- DEVICE_DTS := armada-385-fortinet-fg-50e
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
- sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := kmod-hwmon-nct7802
endef
TARGET_DEVICES += fortinet_fg-50e