summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/mvebu/cortexa9/base-files/etc/board.d/02_network3
-rwxr-xr-xtarget/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh3
-rw-r--r--target/linux/mvebu/files-6.6/arch/arm/boot/dts/marvell/armada-385-fortinet-fwf-51e.dts20
-rw-r--r--target/linux/mvebu/image/cortexa9.mk10
4 files changed, 34 insertions, 2 deletions
diff --git a/target/linux/mvebu/cortexa9/base-files/etc/board.d/02_network b/target/linux/mvebu/cortexa9/base-files/etc/board.d/02_network
index 890c149d30..680af1ce67 100644
--- a/target/linux/mvebu/cortexa9/base-files/etc/board.d/02_network
+++ b/target/linux/mvebu/cortexa9/base-files/etc/board.d/02_network
@@ -31,7 +31,8 @@ mvebu_setup_interfaces()
fortinet,fg-50e|\
fortinet,fg-51e|\
fortinet,fg-52e|\
- fortinet,fwf-50e-2r)
+ fortinet,fwf-50e-2r|\
+ fortinet,fwf-51e)
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 lan5" "eth1 eth2"
;;
iij,sa-w2)
diff --git a/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh
index 639f08cef6..a15823d8c6 100755
--- a/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh
@@ -56,7 +56,8 @@ platform_do_upgrade() {
fortinet,fg-50e|\
fortinet,fg-51e|\
fortinet,fg-52e|\
- fortinet,fwf-50e-2r)
+ fortinet,fwf-50e-2r|\
+ fortinet,fwf-51e)
fortinet_do_upgrade "$1"
;;
iij,sa-w2)
diff --git a/target/linux/mvebu/files-6.6/arch/arm/boot/dts/marvell/armada-385-fortinet-fwf-51e.dts b/target/linux/mvebu/files-6.6/arch/arm/boot/dts/marvell/armada-385-fortinet-fwf-51e.dts
new file mode 100644
index 0000000000..d9ebd9f815
--- /dev/null
+++ b/target/linux/mvebu/files-6.6/arch/arm/boot/dts/marvell/armada-385-fortinet-fwf-51e.dts
@@ -0,0 +1,20 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "armada-385-fortinet-fg-5xe.dtsi"
+
+/ {
+ model = "Fortinet FortiWiFi 51E";
+ compatible = "fortinet,fwf-51e", "marvell,armada385", "marvell,armada380";
+};
+
+&ahci0 {
+ status = "okay";
+};
+
+&pciec {
+ status = "okay";
+};
+
+&pcie2 {
+ status = "okay";
+};
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 5cefdb846a..b3b8960a32 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -171,6 +171,16 @@ define Device/fortinet_fwf-50e-2r
endef
TARGET_DEVICES += fortinet_fwf-50e-2r
+define Device/fortinet_fwf-51e
+ $(Device/fortinet)
+ DEVICE_MODEL := FortiWiFi 51E
+ DEVICE_DTS := armada-385-fortinet-fwf-51e
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | fortigate-header | \
+ gzip-filename FWF51E
+ DEVICE_PACKAGES += kmod-ath9k wpad-basic-mbedtls
+endef
+TARGET_DEVICES += fortinet_fwf-51e
+
define Device/globalscale_mirabox
$(Device/NAND-512K)
DEVICE_VENDOR := Globalscale