summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 402e3d71ed..6fe2890a1a 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -279,9 +279,11 @@ endef
define Build/fit
$(TOPDIR)/scripts/mkits.sh \
-D $(DEVICE_NAME) -o $@.its -k $@ \
- -C $(word 1,$(1)) $(if $(word 2,$(1)),\
- $(if $(DEVICE_DTS_OVERLAY),-d $(KERNEL_BUILD_DIR)/image-$$(basename $(word 2,$(1))),\
- -d $(word 2,$(1)))) \
+ -C $(word 1,$(1)) \
+ $(if $(word 2,$(1)),\
+ $(if $(findstring 11,$(if $(DEVICE_DTS_OVERLAY),1)$(if $(findstring $(KERNEL_BUILD_DIR)/image-,$(word 2,$(1))),,1)), \
+ -d $(KERNEL_BUILD_DIR)/image-$$(basename $(word 2,$(1))), \
+ -d $(word 2,$(1)))) \
$(if $(findstring with-rootfs,$(word 3,$(1))),-r $(IMAGE_ROOTFS)) \
$(if $(findstring with-initrd,$(word 3,$(1))), \
$(if $(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPARATE), \