summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/host-build.mk8
-rw-r--r--include/package-bin.mk2
-rw-r--r--include/package-ipkg.mk2
-rw-r--r--include/package.mk12
-rw-r--r--include/quilt.mk2
5 files changed, 16 insertions, 10 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index cf1203995c..6a335fcbc3 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -35,6 +35,8 @@ override MAKEFLAGS=
include $(INCLUDE_DIR)/quilt.mk
include $(INCLUDE_DIR)/autotools.mk
+_host_target:=$(if $(HOST_QUILT),,.)
+
Host/Patch:=$(Host/Patch/Default)
ifneq ($(strip $(HOST_UNPACK)),)
define Host/Prepare/Default
@@ -176,9 +178,9 @@ ifndef DUMP
)
endif
- .host-prepare: $(HOST_STAMP_PREPARED)
- .host-configure: $(HOST_STAMP_CONFIGURED)
- .host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
+ $(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
+ $(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
+ $(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
host-clean: FORCE
$(call Host/Clean)
$(call Host/Uninstall)
diff --git a/include/package-bin.mk b/include/package-bin.mk
index a777eadad9..ee35ca180f 100644
--- a/include/package-bin.mk
+++ b/include/package-bin.mk
@@ -10,7 +10,7 @@ ifeq ($(DUMP),)
ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
ifdef Package/$(1)/install
ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
- .compile: $(PKG_BUILD_DIR)/.pkgdir/$(1).installed
+ $(_pkg_target)compile: $(PKG_BUILD_DIR)/.pkgdir/$(1).installed
compile: install-bin-$(1)
else
compile: $(1)-disabled
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 8a9c10f64b..d73d461537 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -106,7 +106,7 @@ ifeq ($(DUMP),)
ifdef do_install
ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
IPKGS += $(1)
- .compile: $$(IPKG_$(1)) $(PKG_INFO_DIR)/$(1).provides $(PKG_BUILD_DIR)/.pkgdir/$(1).installed
+ $(_pkg_target)compile: $$(IPKG_$(1)) $(PKG_INFO_DIR)/$(1).provides $(PKG_BUILD_DIR)/.pkgdir/$(1).installed
compile: $(STAGING_DIR_ROOT)/stamp/.$(1)_installed
else
$(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))
diff --git a/include/package.mk b/include/package.mk
index 6e24788a58..95b5f76dc3 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -96,6 +96,8 @@ include $(INCLUDE_DIR)/package-ipkg.mk
include $(INCLUDE_DIR)/package-bin.mk
include $(INCLUDE_DIR)/autotools.mk
+_pkg_target:=$(if $(QUILT),,.)
+
override MAKEFLAGS=
CONFIG_SITE:=$(INCLUDE_DIR)/site/$(ARCH)
CUR_MAKEFILE:=$(filter-out Makefile,$(firstword $(MAKEFILE_LIST)))
@@ -204,13 +206,13 @@ define Build/CoreTargets
touch $$@
ifdef Build/InstallDev
- .compile: $(STAMP_INSTALLED)
+ $(_pkg_target)compile: $(STAMP_INSTALLED)
endif
- .prepare: $(STAMP_PREPARED)
- .configure: $(STAMP_CONFIGURED)
- .dist: $(STAMP_CONFIGURED)
- .distcheck: $(STAMP_CONFIGURED)
+ $(_pkg_target)prepare: $(STAMP_PREPARED)
+ $(_pkg_target)configure: $(STAMP_CONFIGURED)
+ $(_pkg_target)dist: $(STAMP_CONFIGURED)
+ $(_pkg_target)distcheck: $(STAMP_CONFIGURED)
ifneq ($(CONFIG_AUTOREMOVE),)
compile:
diff --git a/include/quilt.mk b/include/quilt.mk
index 796e7160c4..88f84f8cff 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -64,6 +64,7 @@ ifneq ($(PKG_BUILD_DIR),)
ifneq ($(QUILT),)
STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
override CONFIG_AUTOREBUILD=
+ override CONFIG_AUTOREMOVE=
quilt-check: $(STAMP_CHECKED)
endif
endif
@@ -73,6 +74,7 @@ ifneq ($(HOST_BUILD_DIR),)
ifneq ($(HOST_QUILT),)
HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked
override CONFIG_AUTOREBUILD=
+ override CONFIG_AUTOREMOVE=
host-quilt-check: $(HOST_STAMP_CHECKED)
endif
endif