summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md2
-rw-r--r--include/prereq-build.mk10
2 files changed, 5 insertions, 7 deletions
diff --git a/README.md b/README.md
index 68063d9f86..0581a94a09 100644
--- a/README.md
+++ b/README.md
@@ -25,7 +25,7 @@ the [Build System Setup](https://openwrt.org/docs/guide-developer/build-system/i
documentation.
```
-gcc-6+ binutils bzip2 flex python3 perl make4.1+ find grep diff unzip gawk getopt
+gcc-6+ binutils bzip2 flex python3.6+ perl make4.1+ find grep diff unzip gawk getopt
subversion libz-dev libc-dev rsync which
```
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 32edc6e437..b2526a1ec1 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -141,21 +141,19 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
-$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+$(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
- python3.5 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
-$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+$(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
- python3.5 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))