summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/lantiq/files-4.19/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts81
-rw-r--r--target/linux/lantiq/files-5.4/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts81
-rw-r--r--target/linux/lantiq/image/vr9.mk10
-rwxr-xr-xtarget/linux/lantiq/xrx200/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/lantiq/xrx200/base-files/etc/hotplug.d/firmware/12-ath9k-eeprom3
5 files changed, 175 insertions, 1 deletions
diff --git a/target/linux/lantiq/files-4.19/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts b/target/linux/lantiq/files-4.19/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts
new file mode 100644
index 0000000000..215a07e597
--- /dev/null
+++ b/target/linux/lantiq/files-4.19/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts
@@ -0,0 +1,81 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "vr9_avm_fritz736x.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/mips/lantiq_rcu_gphy.h>
+
+/ {
+ compatible = "avm,fritz7360v2", "avm,fritz736x", "lantiq,xway", "lantiq,vr9";
+ model = "AVM FRITZ!Box 7360 V2";
+};
+
+&power_green {
+ label = "fritz7360v2:green:power";
+};
+
+&power_red {
+ label = "fritz7360v2:red:power";
+};
+
+&info_green {
+ label = "fritz7360v2:green:info";
+};
+
+&wifi {
+ label = "fritz7360v2:green:wlan";
+};
+
+&info_red {
+ label = "fritz7360v2:red:info";
+};
+
+&dect {
+ label = "fritz7360v2:green:dect";
+};
+
+&state_default {
+ pcie-rst {
+ lantiq,pins = "io21";
+ lantiq,pull = <0>;
+ lantiq,output = <1>;
+ };
+};
+
+&localbus {
+ flash@0 {
+ compatible = "lantiq,nor";
+ bank-width = <2>;
+ reg = <0 0x0 0x2000000>;
+
+ partitions {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "fixed-partitions";
+
+ urlader: partition@0 {
+ label = "urlader";
+ reg = <0x00000 0x20000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "firmware";
+ reg = <0x20000 0x1f60000>;
+ };
+
+ partition@1f80000 {
+ label = "tffs (1)";
+ reg = <0x1f80000 0x40000>;
+ read-only;
+ };
+
+ partition@1fc0000 {
+ label = "tffs (2)";
+ reg = <0x1fc0000 0x40000>;
+ read-only;
+ };
+ };
+ };
+};
diff --git a/target/linux/lantiq/files-5.4/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts b/target/linux/lantiq/files-5.4/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts
new file mode 100644
index 0000000000..215a07e597
--- /dev/null
+++ b/target/linux/lantiq/files-5.4/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts
@@ -0,0 +1,81 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "vr9_avm_fritz736x.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/mips/lantiq_rcu_gphy.h>
+
+/ {
+ compatible = "avm,fritz7360v2", "avm,fritz736x", "lantiq,xway", "lantiq,vr9";
+ model = "AVM FRITZ!Box 7360 V2";
+};
+
+&power_green {
+ label = "fritz7360v2:green:power";
+};
+
+&power_red {
+ label = "fritz7360v2:red:power";
+};
+
+&info_green {
+ label = "fritz7360v2:green:info";
+};
+
+&wifi {
+ label = "fritz7360v2:green:wlan";
+};
+
+&info_red {
+ label = "fritz7360v2:red:info";
+};
+
+&dect {
+ label = "fritz7360v2:green:dect";
+};
+
+&state_default {
+ pcie-rst {
+ lantiq,pins = "io21";
+ lantiq,pull = <0>;
+ lantiq,output = <1>;
+ };
+};
+
+&localbus {
+ flash@0 {
+ compatible = "lantiq,nor";
+ bank-width = <2>;
+ reg = <0 0x0 0x2000000>;
+
+ partitions {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "fixed-partitions";
+
+ urlader: partition@0 {
+ label = "urlader";
+ reg = <0x00000 0x20000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "firmware";
+ reg = <0x20000 0x1f60000>;
+ };
+
+ partition@1f80000 {
+ label = "tffs (1)";
+ reg = <0x1f80000 0x40000>;
+ read-only;
+ };
+
+ partition@1fc0000 {
+ label = "tffs (2)";
+ reg = <0x1fc0000 0x40000>;
+ read-only;
+ };
+ };
+ };
+};
diff --git a/target/linux/lantiq/image/vr9.mk b/target/linux/lantiq/image/vr9.mk
index 167c57c7c4..d59605a158 100644
--- a/target/linux/lantiq/image/vr9.mk
+++ b/target/linux/lantiq/image/vr9.mk
@@ -127,6 +127,16 @@ define Device/avm_fritz7360sl
endef
TARGET_DEVICES += avm_fritz7360sl
+define Device/avm_fritz7360v2
+ $(Device/AVM)
+ DEVICE_MODEL := FRITZ!Box 7360
+ DEVICE_VARIANT := v2
+ IMAGE_SIZE := 32128k
+ DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic kmod-usb-dwc2
+ SUPPORTED_DEVICES += FRITZ7360V2
+endef
+TARGET_DEVICES += avm_fritz7360v2
+
define Device/avm_fritz7362sl
$(Device/AVM)
$(Device/NAND)
diff --git a/target/linux/lantiq/xrx200/base-files/etc/board.d/02_network b/target/linux/lantiq/xrx200/base-files/etc/board.d/02_network
index f39898263d..790fae58c9 100755
--- a/target/linux/lantiq/xrx200/base-files/etc/board.d/02_network
+++ b/target/linux/lantiq/xrx200/base-files/etc/board.d/02_network
@@ -39,6 +39,7 @@ lantiq_setup_interfaces()
avm,fritz3370-rev2-hynix|\
avm,fritz3370-rev2-micron|\
avm,fritz7360sl|\
+ avm,fritz7360v2|\
avm,fritz7362sl)
ucidef_add_switch "switch0" \
"0:lan:3" "1:lan:4" "2:lan:2" "4:lan:1" "6t@eth0"
diff --git a/target/linux/lantiq/xrx200/base-files/etc/hotplug.d/firmware/12-ath9k-eeprom b/target/linux/lantiq/xrx200/base-files/etc/hotplug.d/firmware/12-ath9k-eeprom
index 6fee72ea8d..4b6d0bf13a 100644
--- a/target/linux/lantiq/xrx200/base-files/etc/hotplug.d/firmware/12-ath9k-eeprom
+++ b/target/linux/lantiq/xrx200/base-files/etc/hotplug.d/firmware/12-ath9k-eeprom
@@ -16,7 +16,8 @@ case "$FIRMWARE" in
avm,fritz7362sl)
caldata_extract_reverse "urlader" 0x1541 0x440
;;
- avm,fritz7360sl)
+ avm,fritz7360sl|\
+ avm,fritz7360v2)
caldata_extract "urlader" 0x985 0x1000
;;
avm,fritz7412)