summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/crypto.mk2
-rw-r--r--package/kernel/linux/modules/fs.mk10
-rw-r--r--package/kernel/linux/modules/i2c.mk2
-rw-r--r--package/kernel/linux/modules/netdevices.mk18
-rw-r--r--package/kernel/linux/modules/netfilter.mk4
-rw-r--r--package/kernel/linux/modules/other.mk4
-rw-r--r--package/kernel/linux/modules/sound.mk3
-rw-r--r--package/kernel/linux/modules/usb.mk6
8 files changed, 19 insertions, 30 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index d43100703e..ed4e51079e 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -42,7 +42,7 @@ define KernelPackage/crypto-aead
CONFIG_CRYPTO_AEAD2
FILES:= \
$(LINUX_DIR)/crypto/aead.ko \
- $(LINUX_DIR)/crypto/geniv.ko@ge5.10
+ $(LINUX_DIR)/crypto/geniv.ko
AUTOLOAD:=$(call AutoLoad,09,aead,1)
$(call AddDepends/crypto, +kmod-crypto-null)
endef
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 06c609b754..6732c7c73a 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -98,13 +98,13 @@ define KernelPackage/fs-cifs
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
DEPENDS+= \
- +(LINUX_5_4||LINUX_5_10):kmod-crypto-md4\
+ +LINUX_5_10:kmod-crypto-md4\
+kmod-crypto-md5 \
+kmod-crypto-sha256 \
+kmod-crypto-sha512 \
+kmod-crypto-cmac \
+kmod-crypto-hmac \
- +(LINUX_5_4||LINUX_5_10):kmod-crypto-arc4 \
+ +LINUX_5_10:kmod-crypto-arc4 \
+kmod-crypto-aead \
+kmod-crypto-ccm \
+kmod-crypto-ecb \
@@ -176,9 +176,7 @@ define KernelPackage/fs-exfat
KCONFIG:= \
CONFIG_EXFAT_FS \
CONFIG_EXFAT_DEFAULT_IOCHARSET="utf8"
- FILES:= \
- $(LINUX_DIR)/drivers/staging/exfat/exfat.ko@lt5.7 \
- $(LINUX_DIR)/fs/exfat/exfat.ko@ge5.7
+ FILES:= $(LINUX_DIR)/fs/exfat/exfat.ko
AUTOLOAD:=$(call AutoLoad,30,exfat,1)
DEPENDS:=+kmod-nls-base
endef
@@ -413,7 +411,7 @@ define KernelPackage/fs-nfs-common
$(LINUX_DIR)/fs/lockd/lockd.ko \
$(LINUX_DIR)/net/sunrpc/sunrpc.ko \
$(LINUX_DIR)/fs/nfs_common/grace.ko \
- $(LINUX_DIR)/fs/nfs_common/nfs_ssc.ko@ge5.10
+ $(LINUX_DIR)/fs/nfs_common/nfs_ssc.ko
AUTOLOAD:=$(call AutoLoad,30,grace sunrpc lockd)
endef
diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index f429763227..15fd1ccddc 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -90,7 +90,7 @@ I2C_DWCORE_MODULES:= \
define KernelPackage/i2c-designware-core
$(call i2c_defaults,$(I2C_DWCORE_MODULES),58)
TITLE:=Synopsys DesignWare I2C core
- DEPENDS:=+kmod-i2c-core +!LINUX_5_4:kmod-regmap-core
+ DEPENDS:=+kmod-i2c-core +kmod-regmap-core
HIDDEN:=y
endef
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 32cd0dcdcd..ff5284276c 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -141,7 +141,7 @@ $(eval $(call KernelPackage,mii))
define KernelPackage/mdio-devres
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Supports MDIO device registration
- DEPENDS:=@(LINUX_5_10||LINUX_5_15) +kmod-libphy +(TARGET_armvirt||TARGET_bcm27xx_bcm2708||TARGET_tegra):kmod-of-mdio
+ DEPENDS:=+kmod-libphy +(TARGET_armvirt||TARGET_bcm27xx_bcm2708||TARGET_tegra):kmod-of-mdio
KCONFIG:=CONFIG_MDIO_DEVRES
HIDDEN:=1
FILES:=$(LINUX_DIR)/drivers/net/phy/mdio_devres.ko
@@ -163,10 +163,8 @@ define KernelPackage/mdio-gpio
CONFIG_MDIO_BITBANG \
CONFIG_MDIO_GPIO
FILES:= \
- $(LINUX_DIR)/drivers/net/phy/mdio-gpio.ko@lt5.10 \
- $(LINUX_DIR)/drivers/net/phy/mdio-bitbang.ko@lt5.10 \
- $(LINUX_DIR)/drivers/net/mdio/mdio-gpio.ko@ge5.10 \
- $(LINUX_DIR)/drivers/net/mdio/mdio-bitbang.ko@ge5.10
+ $(LINUX_DIR)/drivers/net/mdio/mdio-gpio.ko \
+ $(LINUX_DIR)/drivers/net/mdio/mdio-bitbang.ko
AUTOLOAD:=$(call AutoProbe,mdio-gpio)
endef
@@ -593,7 +591,7 @@ $(eval $(call KernelPackage,8139cp))
define KernelPackage/r8169
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=RealTek RTL-8169 PCI Gigabit Ethernet Adapter kernel support
- DEPENDS:=@PCI_SUPPORT +kmod-mii +r8169-firmware +kmod-phy-realtek +(LINUX_5_10||LINUX_5_15):kmod-mdio-devres
+ DEPENDS:=@PCI_SUPPORT +kmod-mii +r8169-firmware +kmod-phy-realtek +kmod-mdio-devres
KCONFIG:= \
CONFIG_R8169 \
CONFIG_R8169_NAPI=y \
@@ -719,7 +717,7 @@ $(eval $(call KernelPackage,igbvf))
define KernelPackage/ixgbe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Intel(R) 82598/82599 PCI-Express 10 Gigabit Ethernet support
- DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core +kmod-libphy +(LINUX_5_10||LINUX_5_15):kmod-mdio-devres
+ DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core +kmod-libphy +kmod-mdio-devres
KCONFIG:=CONFIG_IXGBE \
CONFIG_IXGBE_VXLAN=n \
CONFIG_IXGBE_HWMON=y \
@@ -1072,8 +1070,7 @@ define KernelPackage/of-mdio
DEPENDS:=+kmod-libphy +kmod-fixed-phy @!TARGET_x86
KCONFIG:=CONFIG_OF_MDIO
FILES:= \
- $(LINUX_DIR)/drivers/of/of_mdio.ko@lt5.10 \
- $(LINUX_DIR)/drivers/net/mdio/of_mdio.ko@ge5.10 \
+ $(LINUX_DIR)/drivers/net/mdio/of_mdio.ko \
$(LINUX_DIR)/drivers/net/mdio/fwnode_mdio.ko@ge5.15
AUTOLOAD:=$(call AutoLoad,41,of_mdio)
endef
@@ -1285,8 +1282,7 @@ define KernelPackage/sfp
CONFIG_MDIO_I2C
FILES:= \
$(LINUX_DIR)/drivers/net/phy/sfp.ko \
- $(LINUX_DIR)/drivers/net/phy/mdio-i2c.ko@lt5.10 \
- $(LINUX_DIR)/drivers/net/mdio/mdio-i2c.ko@ge5.10
+ $(LINUX_DIR)/drivers/net/mdio/mdio-i2c.ko
AUTOLOAD:=$(call AutoProbe,mdio-i2c sfp)
endef
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 6b9d620c55..9808649e70 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -176,9 +176,7 @@ define KernelPackage/nf-flow
CONFIG_NF_FLOW_TABLE \
CONFIG_NF_FLOW_TABLE_HW
DEPENDS:=+kmod-nf-conntrack
- FILES:= \
- $(LINUX_DIR)/net/netfilter/nf_flow_table.ko \
- $(if $(CONFIG_LINUX_5_4),$(LINUX_DIR)/net/netfilter/nf_flow_table_hw.ko)
+ FILES:= $(LINUX_DIR)/net/netfilter/nf_flow_table.ko
AUTOLOAD:=$(call AutoProbe,nf_flow_table nf_flow_table_hw)
endef
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 802dd81bed..f5d524e703 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1190,9 +1190,7 @@ define KernelPackage/keys-trusted
TITLE:=TPM trusted keys on kernel keyring
DEPENDS:=@KERNEL_KEYS +kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha1 +kmod-tpm
KCONFIG:=CONFIG_TRUSTED_KEYS
- FILES:= \
- $(LINUX_DIR)/security/keys/trusted.ko@lt5.10 \
- $(LINUX_DIR)/security/keys/trusted-keys/trusted.ko@ge5.10
+ FILES:= $(LINUX_DIR)/security/keys/trusted-keys/trusted.ko
AUTOLOAD:=$(call AutoLoad,01,trusted-keys,1)
endef
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 83b3355f3f..2bfa146207 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -523,8 +523,7 @@ define KernelPackage/sound-hda-intel
CONFIG_SND_HDA_INTEL
FILES:= \
$(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko \
- $(LINUX_DIR)/sound/hda/snd-intel-nhlt.ko@lt5.5 \
- $(LINUX_DIR)/sound/hda/snd-intel-dspcfg.ko@ge5.5
+ $(LINUX_DIR)/sound/hda/snd-intel-dspcfg.ko
AUTOLOAD:=$(call AutoProbe,snd-hda-intel)
$(call AddDepends/sound,kmod-sound-hda-core)
endef
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 0bc578e5a7..19c44f805b 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1250,7 +1250,7 @@ $(eval $(call KernelPackage,usb-net-mcs7830))
define KernelPackage/usb-net-smsc75xx
TITLE:=SMSC LAN75XX based USB 2.0 Gigabit ethernet devices
- DEPENDS:=+!LINUX_5_4:kmod-libphy
+ DEPENDS:=+kmod-libphy
KCONFIG:=CONFIG_USB_NET_SMSC75XX
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/smsc75xx.ko
AUTOLOAD:=$(call AutoProbe,smsc75xx)
@@ -1266,7 +1266,7 @@ $(eval $(call KernelPackage,usb-net-smsc75xx))
define KernelPackage/usb-net-smsc95xx
TITLE:=SMSC LAN95XX based USB 2.0 10/100 ethernet devices
- DEPENDS:=+(LINUX_5_10||LINUX_5_15):kmod-libphy
+ DEPENDS:=+kmod-libphy
KCONFIG:=CONFIG_USB_NET_SMSC95XX
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/smsc95xx.ko
AUTOLOAD:=$(call AutoProbe,smsc95xx)
@@ -1439,7 +1439,7 @@ define KernelPackage/usb-net-cdc-ncm
KCONFIG:=CONFIG_USB_NET_CDC_NCM
FILES:= $(LINUX_DIR)/drivers/$(USBNET_DIR)/cdc_ncm.ko
AUTOLOAD:=$(call AutoProbe,cdc_ncm)
- $(call AddDepends/usb-net,+!LINUX_5_4:kmod-usb-net-cdc-ether)
+ $(call AddDepends/usb-net,+kmod-usb-net-cdc-ether)
endef
define KernelPackage/usb-net-cdc-ncm/description