summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/kirkwood/patches-5.4/800-power-reset-linkstation-poweroff-prepare-for-new-dev.patch11
-rw-r--r--target/linux/kirkwood/patches-5.4/801-power-reset-linkstation-poweroff-add-new-device.patch9
3 files changed, 7 insertions, 17 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 9cd2b77e16..5d462f7b06 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-5.4 = .169
+LINUX_VERSION-5.4 = .170
LINUX_VERSION-5.10 = .89
-LINUX_KERNEL_HASH-5.4.169 = 554382d95f71afd5f9b49292eb5d1cbe3be1a0bad22d21487c9e6d506ee01a19
+LINUX_KERNEL_HASH-5.4.170 = b09f74e0cf5fc7cf5de6aa932fe654c962cb10118bdbbdddb397022c6e6d382c
LINUX_KERNEL_HASH-5.10.89 = 92218b1a4a18f1cb9ec07d2b7fce41577452aa552c54c25b6d5fe9b4b543bb30
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/kirkwood/patches-5.4/800-power-reset-linkstation-poweroff-prepare-for-new-dev.patch b/target/linux/kirkwood/patches-5.4/800-power-reset-linkstation-poweroff-prepare-for-new-dev.patch
index 03253cfe83..4b4d03839a 100644
--- a/target/linux/kirkwood/patches-5.4/800-power-reset-linkstation-poweroff-prepare-for-new-dev.patch
+++ b/target/linux/kirkwood/patches-5.4/800-power-reset-linkstation-poweroff-prepare-for-new-dev.patch
@@ -15,8 +15,6 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
drivers/power/reset/linkstation-poweroff.c | 35 ++++++++++++++++++----
1 file changed, 29 insertions(+), 6 deletions(-)
-diff --git a/drivers/power/reset/linkstation-poweroff.c b/drivers/power/reset/linkstation-poweroff.c
-index f1e843df0e16..8691cf98600d 100644
--- a/drivers/power/reset/linkstation-poweroff.c
+++ b/drivers/power/reset/linkstation-poweroff.c
@@ -29,11 +29,21 @@
@@ -42,7 +40,7 @@ index f1e843df0e16..8691cf98600d 100644
saved_page = phy_select_page(phydev, MII_MARVELL_LED_PAGE);
if (saved_page < 0)
-@@ -66,11 +76,16 @@ static void mvphy_reg_intn(u16 data)
+@@ -66,11 +76,16 @@ err:
dev_err(&phydev->mdio.dev, "Write register failed, %d\n", rc);
}
@@ -60,7 +58,7 @@ index f1e843df0e16..8691cf98600d 100644
return NOTIFY_DONE;
}
-@@ -82,14 +97,18 @@ static struct notifier_block linkstation_reboot_nb = {
+@@ -82,14 +97,18 @@ static struct notifier_block linkstation
static void linkstation_poweroff(void)
{
unregister_reboot_notifier(&linkstation_reboot_nb);
@@ -82,7 +80,7 @@ index f1e843df0e16..8691cf98600d 100644
{ },
};
-@@ -97,13 +116,17 @@ static int __init linkstation_poweroff_init(void)
+@@ -97,13 +116,17 @@ static int __init linkstation_poweroff_i
{
struct mii_bus *bus;
struct device_node *dn;
@@ -101,6 +99,3 @@ index f1e843df0e16..8691cf98600d 100644
if (!dn)
return -ENODEV;
---
-2.25.1
-
diff --git a/target/linux/kirkwood/patches-5.4/801-power-reset-linkstation-poweroff-add-new-device.patch b/target/linux/kirkwood/patches-5.4/801-power-reset-linkstation-poweroff-add-new-device.patch
index 0b3b4ad2d7..a929aacfd0 100644
--- a/target/linux/kirkwood/patches-5.4/801-power-reset-linkstation-poweroff-add-new-device.patch
+++ b/target/linux/kirkwood/patches-5.4/801-power-reset-linkstation-poweroff-add-new-device.patch
@@ -17,8 +17,6 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
drivers/power/reset/linkstation-poweroff.c | 43 ++++++++++++++++++++++
1 file changed, 43 insertions(+)
-diff --git a/drivers/power/reset/linkstation-poweroff.c b/drivers/power/reset/linkstation-poweroff.c
-index 8691cf98600d..2a92b6052cac 100644
--- a/drivers/power/reset/linkstation-poweroff.c
+++ b/drivers/power/reset/linkstation-poweroff.c
@@ -19,6 +19,7 @@
@@ -38,7 +36,7 @@ index 8691cf98600d..2a92b6052cac 100644
struct power_off_cfg {
char *mdio_node_name;
void (*phy_set_reg)(bool restart);
-@@ -76,11 +79,48 @@ static void linkstation_mvphy_reg_intn(bool restart)
+@@ -76,11 +79,48 @@ err:
dev_err(&phydev->mdio.dev, "Write register failed, %d\n", rc);
}
@@ -87,7 +85,7 @@ index 8691cf98600d..2a92b6052cac 100644
static int linkstation_reboot_notifier(struct notifier_block *nb,
unsigned long action, void *unused)
{
-@@ -109,6 +149,9 @@ static const struct of_device_id ls_poweroff_of_match[] = {
+@@ -109,6 +149,9 @@ static const struct of_device_id ls_powe
{ .compatible = "buffalo,ls421de",
.data = &linkstation_power_off_cfg,
},
@@ -97,6 +95,3 @@ index 8691cf98600d..2a92b6052cac 100644
{ },
};
---
-2.25.1
-