summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-build.in10
-rw-r--r--rules.mk2
2 files changed, 5 insertions, 7 deletions
diff --git a/config/Config-build.in b/config/Config-build.in
index df2d9101ca..f8d0f8e0bd 100644
--- a/config/Config-build.in
+++ b/config/Config-build.in
@@ -182,7 +182,6 @@ menu "Global build settings"
help
This will install binaries stripped using strip from binutils.
-
config USE_SSTRIP
bool "sstrip"
depends on !USE_GLIBC
@@ -199,13 +198,12 @@ menu "Global build settings"
help
Specifies arguments passed to the strip command when stripping binaries.
- config SSTRIP_ARGS
- string
- prompt "Sstrip arguments"
+ config SSTRIP_DISCARD_TRAILING_ZEROES
+ bool "Strip trailing zero bytes"
depends on USE_SSTRIP
- default "-z"
+ default y
help
- Specifies arguments passed to the sstrip command when stripping binaries.
+ Use sstrip's -z option to discard trailing zero bytes
config STRIP_KERNEL_EXPORTS
bool "Strip unnecessary exports from the kernel image"
diff --git a/rules.mk b/rules.mk
index 1cedd91aa8..ca27583d27 100644
--- a/rules.mk
+++ b/rules.mk
@@ -330,7 +330,7 @@ else
STRIP:=$(TARGET_CROSS)strip $(call qstrip,$(CONFIG_STRIP_ARGS))
else
ifneq ($(CONFIG_USE_SSTRIP),)
- STRIP:=$(STAGING_DIR_HOST)/bin/sstrip $(call qstrip,$(CONFIG_SSTRIP_ARGS))
+ STRIP:=$(STAGING_DIR_HOST)/bin/sstrip $(if $(CONFIG_SSTRIP_DISCARD_TRAILING_ZEROES),-z)
endif
endif
RSTRIP= \