summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-envtools/files/ath793
-rw-r--r--target/linux/ath79/dts/qca9550_dell_apl26-0ae.dts228
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/01_leds4
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ath79/image/generic.mk16
5 files changed, 255 insertions, 0 deletions
diff --git a/package/boot/uboot-envtools/files/ath79 b/package/boot/uboot-envtools/files/ath79
index 4a6e7e4d0a..099aebcfa2 100644
--- a/package/boot/uboot-envtools/files/ath79
+++ b/package/boot/uboot-envtools/files/ath79
@@ -109,6 +109,9 @@ buffalo,wzr-hp-g300nh-s|\
linksys,ea4500-v3)
ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x20000" "0x20000"
;;
+dell,apl26-0ae)
+ ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x40000" "0x10000"
+ ;;
domywifi,dw33d)
ubootenv_add_uci_config "/dev/mtd4" "0x0" "0x10000" "0x10000"
;;
diff --git a/target/linux/ath79/dts/qca9550_dell_apl26-0ae.dts b/target/linux/ath79/dts/qca9550_dell_apl26-0ae.dts
new file mode 100644
index 0000000000..6ef2eb846d
--- /dev/null
+++ b/target/linux/ath79/dts/qca9550_dell_apl26-0ae.dts
@@ -0,0 +1,228 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+
+#include "qca955x.dtsi"
+
+/ {
+ model = "Dell SonicPoint ACe (APL26-0AE)";
+ compatible = "dell,apl26-0ae", "qca,qca9550", "qca,qca9558";
+
+ aliases {
+ label-mac-device = &eth0;
+ led-boot = &led_wrench;
+ led-failsafe = &led_wrench;
+ led-upgrade = &led_wrench;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ button-reset {
+ label = "reset";
+ gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ /* Accessible only after disassembling the casing */
+ button-service {
+ label = "service";
+ gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_POWER>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+ pinctrl-names = "default";
+ pinctrl-0 = <&jtag_disable_pins>;
+
+ led-lan1-amber {
+ color = <LED_COLOR_ID_AMBER>;
+ function = LED_FUNCTION_LAN;
+ function-enumerator = <1>;
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ };
+
+ led-lan1-green {
+ color = <LED_COLOR_ID_GREEN>;
+ function = LED_FUNCTION_LAN;
+ function-enumerator = <1>;
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ };
+
+ led-lan2-amber {
+ color = <LED_COLOR_ID_AMBER>;
+ function = LED_FUNCTION_LAN;
+ function-enumerator = <2>;
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ };
+
+ led-lan2-green {
+ color = <LED_COLOR_ID_GREEN>;
+ function = LED_FUNCTION_LAN;
+ function-enumerator = <2>;
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ };
+
+ led-wlan2g {
+ color = <LED_COLOR_ID_GREEN>;
+ function = LED_FUNCTION_WLAN_2GHZ;
+ linux,default-trigger = "phy1tpt";
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ };
+
+ led-wlan5g {
+ color = <LED_COLOR_ID_GREEN>;
+ function = LED_FUNCTION_WLAN_5GHZ;
+ linux,default-trigger = "phy0tpt";
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ };
+
+ led_wrench: led-wrench {
+ color = <LED_COLOR_ID_AMBER>;
+ function = LED_FUNCTION_STATUS;
+ gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ nvmem-cells = <&macaddr_sysinfo_50 0>;
+ nvmem-cell-names = "mac-address";
+ phy-handle = <&phy0>;
+ pll-data = <0xa6000000 0x00000101 0x00001616>;
+};
+
+&eth1 {
+ status = "okay";
+
+ nvmem-cells = <&macaddr_sysinfo_50 1>;
+ nvmem-cell-names = "mac-address";
+ pll-data = <0x03000101 0x00000101 0x00001616>;
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ };
+};
+
+&mdio0 {
+ status = "okay";
+
+ phy0: ethernet-phy@0 {
+ reg = <0>;
+
+ qca,ar8327-initvals = <
+ 0x04 0x07680000 /* PORT0 PAD MODE CTRL */
+ 0x0c 0x00000080 /* PORT6 PAD MODE CTRL */
+ 0x10 0x40000000 /* POWER_ON_STRAP */
+ 0x50 0xffb7c405 /* LED0 CTRL */
+ 0x54 0xffb7c305 /* LED1 CTRL */
+ 0x58 0xffb7c033 /* LED2 CTRL */
+ 0x5c 0x03ffff00 /* LED3 CTRL */
+ 0x7c 0x0000007e /* PORT0_STATUS */
+ 0x94 0x0000007e /* PORT6_STATUS */
+ >;
+ };
+};
+
+&pcie0 {
+ status = "okay";
+
+ wifi@0,0 {
+ compatible = "qcom,ath10k";
+ reg = <0x0000 0 0 0 0>;
+
+ /* OEM overwrites EEPROM stored adress and so do we */
+ nvmem-cells = <&macaddr_sysinfo_50 2>;
+ nvmem-cell-names = "mac-address";
+ };
+};
+
+&spi {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+ broken-flash-reset;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0000000 0x0080000>;
+ read-only;
+ };
+
+ partition@80000 {
+ label = "u-boot-env";
+ reg = <0x0080000 0x0040000>;
+ };
+
+ partition@c0000 {
+ label = "sysinfo";
+ reg = <0x00c0000 0x0040000>;
+ read-only;
+
+ nvmem-layout {
+ compatible = "fixed-layout";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_sysinfo_50: macaddr@50 {
+ compatible = "mac-base";
+ reg = <0x50 0x6>;
+ #nvmem-cell-cells = <1>;
+ };
+ };
+ };
+
+ partition@100000 {
+ label = "art";
+ reg = <0x0100000 0x0010000>;
+ read-only;
+
+ nvmem-layout {
+ compatible = "fixed-layout";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ cal_art_1000: calibration@1000 {
+ reg = <0x1000 0x440>;
+ };
+ };
+ };
+
+ partition@110000 {
+ label = "firmware";
+ reg = <0x0110000 0x1ef0000>;
+ compatible = "denx,uimage";
+ };
+ };
+ };
+};
+
+&usb_phy0 {
+ status = "okay";
+};
+
+&usb0 {
+ status = "okay";
+};
+
+&wmac {
+ status = "okay";
+
+ nvmem-cells = <&macaddr_sysinfo_50 10>, <&cal_art_1000>;
+ nvmem-cell-names = "mac-address", "calibration";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 98d1b0a7ba..143309a8b2 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -232,6 +232,10 @@ compex,wpj531-16m)
ucidef_set_led_rssi "sig3" "SIG3" "green:sig3" "wlan0" "65" "100"
ucidef_set_led_rssi "sig4" "SIG4" "green:sig4" "wlan0" "50" "100"
;;
+dell,apl26-0ae)
+ ucidef_set_led_switch "lan1" "LAN1" "amber:lan-1" "switch0" "0x04"
+ ucidef_set_led_switch "lan2" "LAN2" "amber:lan-2" "switch0" "0x08"
+ ;;
devolo,dlan-pro-1200plus-ac|\
devolo,magic-2-wifi)
ucidef_set_led_netdev "plcw" "dLAN" "white:dlan" "eth0.1" "rx"
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 8af618d267..7905d6e496 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -288,6 +288,10 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"1:wan" "5:lan" "6@eth0"
;;
+ dell,apl26-0ae)
+ ucidef_add_switch "switch0" \
+ "0@eth0" "2:lan:1" "3:lan:2" "6@eth1"
+ ;;
devolo,dlan-pro-1200plus-ac|\
devolo,magic-2-wifi)
ucidef_add_switch "switch0" \
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ca72c8c6d8..0da5a0ef8d 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -944,6 +944,22 @@ define Device/compex_wpj563
endef
TARGET_DEVICES += compex_wpj563
+define Device/dell_apl26-0ae
+ SOC := qca9550
+ DEVICE_VENDOR := Dell
+ DEVICE_MODEL := SonicPoint
+ DEVICE_VARIANT := ACe (APL26-0AE)
+ DEVICE_ALT0_VENDOR := SonicWall
+ DEVICE_ALT0_MODEL := SonicPoint
+ DEVICE_ALT0_VARIANT := ACe (APL26-0AE)
+ DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct kmod-usb2
+ KERNEL_SIZE := 5952k
+ IMAGE_SIZE := 31680k
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | append-metadata
+endef
+TARGET_DEVICES += dell_apl26-0ae
+
define Device/devolo_dlan-pro-1200plus-ac
SOC := ar9344
DEVICE_VENDOR := devolo