summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/download.mk b/include/download.mk
index 63ded7ebcd..09b929bd77 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -9,6 +9,12 @@
OPENWRT_GIT = http://git.openwrt.org
LEDE_GIT = https://git.lede-project.org
+ifdef PKG_SOURCE_VERSION
+PKG_VERSION ?= $(if $(PKG_SOURCE_DATE),$(PKG_SOURCE_DATE)-)$(call version_abbrev,$(PKG_SOURCE_VERSION))
+PKG_SOURCE_SUBDIR ?= $(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE ?= $(PKG_SOURCE_SUBDIR).tar.xz
+endif
+
DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
# Try to guess the download method from the URL