summaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index f88e853b52..8a6c4bb468 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -25,21 +25,21 @@ $(eval $(call TestHostCommand,proper-umask, \
ifndef IB
$(eval $(call SetupHostCommand,gcc, \
- Please install the GNU C Compiler (gcc) 4.8 or later, \
- $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
- gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+ Please install the GNU C Compiler (gcc) 6 or later, \
+ $(CC) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+ gcc -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
gcc --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-gcc, \
- \nPlease reinstall the GNU C Compiler (4.8 or later) - \
+ \nPlease reinstall the GNU C Compiler (6 or later) - \
it appears to be broken, \
echo 'int main(int argc, char **argv) { return 0; }' | \
gcc -x c -o $(TMP_DIR)/a.out -))
$(eval $(call SetupHostCommand,g++, \
- Please install the GNU C++ Compiler (g++) 4.8 or later, \
- $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
- g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+ Please install the GNU C++ Compiler (g++) 6 or later, \
+ $(CXX) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+ g++ -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
g++ --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-g++, \