summaryrefslogtreecommitdiffstats
path: root/include/prereq.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq.mk')
-rw-r--r--include/prereq.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index c11178a884..23d5ded9b2 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -49,7 +49,7 @@ endef
define RequireCommand
define Require/$(1)
- command -pv $(1)
+ which $(1)
endef
$$(eval $$(call Require,$(1),$(2)))
@@ -103,7 +103,7 @@ define SetupHostCommand
$(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
if [ -n "$$$$$$$$cmd" ]; then \
bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
- command -pv "$$$$$$$${cmd%% *}")"; \
+ which "$$$$$$$${cmd%% *}")"; \
if [ -x "$$$$$$$$bin" ] && eval "$$$$$$$$cmd" >/dev/null 2>/dev/null; then \
mkdir -p "$(STAGING_DIR_HOST)/bin"; \
ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \