summaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 61489cabe7..3523d045ae 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -218,6 +218,11 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_arc700 = -mcpu=arc700
CPU_CFLAGS_archs = -mcpu=archs
endif
+ ifneq ($(CPU_TYPE),)
+ ifndef CPU_CFLAGS_$(CPU_TYPE)
+ $(warning CPU_TYPE "$(CPU_TYPE)" doesn't correspond to a known type)
+ endif
+ endif
DEFAULT_CFLAGS=$(strip $(CPU_CFLAGS) $(CPU_CFLAGS_$(CPU_TYPE)) $(CPU_CFLAGS_$(CPU_SUBTYPE)))
ifneq ($(BOARD),)