summaryrefslogtreecommitdiffstats
path: root/include/uclibc++.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/uclibc++.mk')
-rw-r--r--include/uclibc++.mk18
1 files changed, 2 insertions, 16 deletions
diff --git a/include/uclibc++.mk b/include/uclibc++.mk
index a1a61f26d4..10f8d98e15 100644
--- a/include/uclibc++.mk
+++ b/include/uclibc++.mk
@@ -1,16 +1,2 @@
-ifndef DUMP
- ifdef __package_mk
- $(error uclibc++.mk must be included before package.mk)
- endif
-endif
-
-PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
-CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
-
-ifneq ($(CONFIG_USE_UCLIBCXX),)
- ifneq ($(CONFIG_CCACHE),)
- TARGET_CXX_NOCACHE=g++-uc
- else
- TARGET_CXX=g++-uc
- endif
-endif
+$(warn uclibc++.mk is deprecated. Please remove it and CXX_DEPENDS)
+CXX_DEPENDS = +libstdcpp