summaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 4b8df7f484..8e72d4ec72 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -106,6 +106,14 @@ ifdef CONFIG_SIGNED_PACKAGES
$(STAGING_DIR_HOST)/bin/usign -S -m Packages -s $(BUILD_KEY); \
); done
endif
+ifdef CONFIG_JSON_CYCLONEDX_SBOM
+ @echo Creating CycloneDX package SBOMs...
+ @for d in $(PACKAGE_SUBDIRS); do ( \
+ [ -d $$d ] && \
+ cd $$d || continue; \
+ $(SCRIPT_DIR)/package-metadata.pl pkgcyclonedxsbom Packages.manifest > Packages.bom.cdx.json || true; \
+ ); done
+endif
$(curdir)/flags-install:= -j1