summaryrefslogtreecommitdiffstats
path: root/package/libs/libpcap/patches/100-debian_shared_lib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libpcap/patches/100-debian_shared_lib.patch')
-rw-r--r--package/libs/libpcap/patches/100-debian_shared_lib.patch168
1 files changed, 0 insertions, 168 deletions
diff --git a/package/libs/libpcap/patches/100-debian_shared_lib.patch b/package/libs/libpcap/patches/100-debian_shared_lib.patch
deleted file mode 100644
index 454490fbfa..0000000000
--- a/package/libs/libpcap/patches/100-debian_shared_lib.patch
+++ /dev/null
@@ -1,168 +0,0 @@
-Debian-specific modifications to the upstream Makefile.in to
-build a shared library.
-
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -40,6 +40,13 @@ mandir = @mandir@
- srcdir = @srcdir@
- VPATH = @srcdir@
-
-+# some defines for shared library compilation
-+LIBVERSION=1
-+LIBNAME=pcap
-+LIBRARY=lib$(LIBNAME).a
-+SOLIBRARY=lib$(LIBNAME).so
-+SHAREDLIB=$(SOLIBRARY).$(LIBVERSION)
-+
- #
- # You shouldn't need to edit anything below.
- #
-@@ -69,7 +76,8 @@ INSTALL_RPCAPD=@INSTALL_RPCAPD@
- EXTRA_NETWORK_LIBS=@EXTRA_NETWORK_LIBS@
-
- # Standard CFLAGS for building members of a shared library
--FULL_CFLAGS = $(CCOPT) @V_LIB_CCOPT_FAT@ $(SHLIB_CCOPT) $(INCLS) $(DEFS) $(CFLAGS)
-+FULL_CFLAGS = $(CCOPT) @V_LIB_CCOPT_FAT@ $(SHLIB_CCOPT) $(INCLS) $(DEFS) $(CFLAGS) $(CPPFLAGS)
-+CFLAGS_SHARED = -shared -Wl,-soname,$(SHAREDLIB)
-
- INSTALL = @INSTALL@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -84,7 +92,11 @@ YACC = @YACC@
- # problem if you don't own the file but can write to the directory.
- .c.o:
- @rm -f $@
-- $(CC) $(FULL_CFLAGS) -c $(srcdir)/$*.c
-+ $(CC) $(FULL_CFLAGS) -c -o $@ $(srcdir)/$*.c
-+
-+%_pic.o: %.c %.o
-+ @rm -f $@
-+ $(CC) -fPIC $(FULL_CFLAGS) -c -o $@ $(srcdir)/$*.c
-
- PSRC = pcap-@V_PCAP@.c @USB_SRC@ @BT_SRC@ @BT_MONITOR_SRC@ @NETFILTER_SRC@ @DBUS_SRC@ @NETMAP_SRC@ @RDMA_SRC@
- FSRC = @V_FINDALLDEVS@
-@@ -101,6 +113,7 @@ SRC = $(PSRC) $(FSRC) $(CSRC) $(SSRC) $(
- # We would like to say "OBJ = $(SRC:.c=.o)" but Ultrix's make cannot
- # hack the extra indirection
- OBJ = $(PSRC:.c=.o) $(FSRC:.c=.o) $(CSRC:.c=.o) $(SSRC:.c=.o) $(GENSRC:.c=.o) $(LIBOBJS)
-+OBJ_PIC = $(PSRC:.c=_pic.o) $(FSRC:.c=_pic.o) $(CSRC:.c=_pic.o) $(SSRC:.c=_pic.o) $(GENSRC:.c=_pic.o)
- PUBHDR = \
- pcap.h \
- pcap-bpf.h \
-@@ -155,7 +168,7 @@ TAGFILES = \
-
- CLEANFILES = $(OBJ) libpcap.a libpcap.so.`cat $(srcdir)/VERSION` \
- $(PROG)-`cat $(srcdir)/VERSION`.tar.gz $(GENSRC) $(GENHDR) \
-- lex.yy.c pcap-config libpcap.pc
-+ lex.yy.c pcap-config libpcap.pc $(OBJ_PIC)
-
- MAN1 = pcap-config.1
-
-@@ -392,7 +405,7 @@ libpcap.a: $(OBJ)
- $(AR) rc $@ $(OBJ) $(ADDLARCHIVEOBJS)
- $(RANLIB) $@
-
--shared: libpcap.$(DYEXT)
-+shared: $(SHAREDLIB)
-
- libpcap.so: $(OBJ)
- @rm -f $@
-@@ -468,6 +481,12 @@ libpcap.shareda: $(OBJ)
- #
- libpcap.none:
-
-+$(SHAREDLIB): $(OBJ_PIC)
-+ -@rm -f $@
-+ -@rm -f $(SOLIBRARY)
-+ $(CC) $(CFLAGS_SHARED) $(LDFLAGS) -o $(SHAREDLIB) $(OBJ_PIC) -lc $(LIBS)
-+ ln -s $(SHAREDLIB) $(SOLIBRARY)
-+
- scanner.c: $(srcdir)/scanner.l
- $(LEX) -P pcap_ --header-file=scanner.h --nounput -o scanner.c $<
- scanner.h: scanner.c
-@@ -480,6 +499,9 @@ scanner.h: scanner.c
- scanner.o: scanner.c grammar.h
- $(CC) $(FULL_CFLAGS) -c scanner.c
-
-+scanner_pic.o: scanner.c grammar.h
-+ $(CC) -fPIC $(FULL_CFLAGS) -o $@ -c scanner.c
-+
- grammar.c: $(srcdir)/grammar.y
- $(YACC) -p pcap_ -o grammar.c -d $<
- grammar.h: grammar.c
-@@ -492,6 +514,9 @@ grammar.h: grammar.c
- grammar.o: grammar.c scanner.h
- $(CC) $(FULL_CFLAGS) -c grammar.c
-
-+grammar_pic.o: grammar.c scanner.h
-+ $(CC) -fPIC $(FULL_CFLAGS) -o $@ -c grammar.c
-+
- gencode.o: $(srcdir)/gencode.c grammar.h scanner.h
- $(CC) $(FULL_CFLAGS) -c $(srcdir)/gencode.c
-
-@@ -539,6 +564,9 @@ pcap-config: $(srcdir)/pcap-config.in ./
- mv $@.tmp $@
- chmod a+x $@
-
-+bpf_filter_pic.o: bpf_filter.c
-+ $(CC) -fPIC $(FULL_CFLAGS) -c bpf_filter.c -o $@
-+
- #
- # Remote pcap daemon.
- #
-@@ -632,14 +660,11 @@ install: install-shared install-archive
- $(DESTDIR)$(mandir)/man@MAN_MISC_INFO@/`echo $$i | sed 's/.manmisc.in/.@MAN_MISC_INFO@/'`; done
-
- install-shared: install-shared-$(DYEXT)
--install-shared-so: libpcap.so
-+install-shared-so: $(SHAREDLIB)
- [ -d $(DESTDIR)$(libdir) ] || \
- (mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir))
-- VER=`cat $(srcdir)/VERSION`; \
-- MAJOR_VER=`sed 's/\([0-9][0-9]*\)\..*/\1/' $(srcdir)/VERSION`; \
-- $(INSTALL_PROGRAM) libpcap.so.$$VER $(DESTDIR)$(libdir)/libpcap.so.$$VER; \
-- ln -sf libpcap.so.$$VER $(DESTDIR)$(libdir)/libpcap.so.$$MAJOR_VER; \
-- ln -sf libpcap.so.$$MAJOR_VER $(DESTDIR)$(libdir)/libpcap.so
-+ $(INSTALL_DATA) $(SHAREDLIB) $(DESTDIR)$(libdir)/
-+ ln -sf $(SHAREDLIB) $(DESTDIR)$(libdir)/$(SOLIBRARY)
- install-shared-dylib: libpcap.dylib
- [ -d $(DESTDIR)$(libdir) ] || \
- (mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir))
---- a/aclocal.m4
-+++ b/aclocal.m4
-@@ -507,7 +507,7 @@ AC_DEFUN(AC_LBL_SHLIBS_INIT,
- esac
- ;;
- esac
-- V_SHLIB_CCOPT="$V_SHLIB_CCOPT $PIC_OPT"
-+ V_SHLIB_CCOPT="$V_SHLIB_CCOPT"
- V_SONAME_OPT="-Wl,-soname,"
- V_RPATH_OPT="-Wl,-rpath,"
- ;;
-@@ -570,7 +570,7 @@ AC_DEFUN(AC_LBL_SHLIBS_INIT,
- #
- # "cc" is GCC.
- #
-- V_SHLIB_CCOPT="$V_SHLIB_CCOPT -fpic"
-+ V_SHLIB_CCOPT="$V_SHLIB_CCOPT"
- V_SHLIB_CMD="\$(CC)"
- V_SHLIB_OPT="-shared"
- V_SONAME_OPT="-Wl,-soname,"
---- a/pcap-config.in
-+++ b/pcap-config.in
-@@ -41,16 +41,6 @@ do
- esac
- shift
- done
--if [ "$V_RPATH_OPT" != "" ]
--then
-- #
-- # If libdir isn't /usr/lib, add it to the run-time linker path.
-- #
-- if [ "$libdir" != "/usr/lib" ]
-- then
-- RPATH=$V_RPATH_OPT$libdir
-- fi
--fi
- if [ "$static" = 1 ]
- then
- #