summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/Makefile10
-rw-r--r--target/linux/at91/image/sama5.mk71
-rw-r--r--target/linux/at91/image/sama5d2.mk31
-rw-r--r--target/linux/at91/image/sama5d3.mk33
-rw-r--r--target/linux/at91/image/sama5d4.mk19
5 files changed, 73 insertions, 91 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 49d93aa97d..f4d942b682 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -16,14 +16,8 @@ endef
ifeq ($(SUBTARGET),legacy)
include ./legacy.mk
endif
-ifeq ($(SUBTARGET),sama5d2)
-include ./sama5d2.mk
-endif
-ifeq ($(SUBTARGET),sama5d3)
-include ./sama5d3.mk
-endif
-ifeq ($(SUBTARGET),sama5d4)
-include ./sama5d4.mk
+ifeq ($(SUBTARGET),sama5)
+include ./sama5.mk
endif
AT91_SD_BOOT_PARTSIZE:=64
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
new file mode 100644
index 0000000000..f9a190c8b2
--- /dev/null
+++ b/target/linux/at91/image/sama5.mk
@@ -0,0 +1,71 @@
+
+define Device/default-nand
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
+endef
+
+define Device/at91-sama5d2_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d2_xplained
+
+define Device/at91-sama5d27_som1_ek
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d27_som1_ek
+
+define Device/at91-sama5d2_ptc_ek
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 PTC Ek
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d2_ptc_ek
+
+
+define Device/at91-sama5d3_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d3_xplained
+
+ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+ define Device/wb50n
+ $(Device/evaluation-fit)
+ DEVICE_TITLE := Laird WB50N
+ DEVICE_PACKAGES := \
+ kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
+ kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
+ kmod-leds-gpio
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+ endef
+ TARGET_DEVICES += wb50n
+ endif
+endif
+
+
+define Device/at91-sama5d4_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
+ KERNEL_SIZE := 6144k
+ BLOCKSIZE := 256k
+ PAGESIZE := 4096
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d4_xplained
diff --git a/target/linux/at91/image/sama5d2.mk b/target/linux/at91/image/sama5d2.mk
deleted file mode 100644
index b841448633..0000000000
--- a/target/linux/at91/image/sama5d2.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-
-define Device/default-nand
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
-endef
-
-define Device/at91-sama5d2_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d2_xplained
-
-define Device/at91-sama5d27_som1_ek
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d27_som1_ek
-
-define Device/at91-sama5d2_ptc_ek
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 PTC Ek
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d2_ptc_ek
diff --git a/target/linux/at91/image/sama5d3.mk b/target/linux/at91/image/sama5d3.mk
index f48c981030..e69de29bb2 100644
--- a/target/linux/at91/image/sama5d3.mk
+++ b/target/linux/at91/image/sama5d3.mk
@@ -1,33 +0,0 @@
-
-define Device/default-nand
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
-endef
-
-define Device/at91-sama5d3_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d3_xplained
-
-ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
- ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
- define Device/wb50n
- $(Device/evaluation-fit)
- DEVICE_TITLE := Laird WB50N
- DEVICE_PACKAGES := \
- kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
- kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
- kmod-leds-gpio
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
- endef
- TARGET_DEVICES += wb50n
- endif
-endif
diff --git a/target/linux/at91/image/sama5d4.mk b/target/linux/at91/image/sama5d4.mk
index 1140c3c4b2..e69de29bb2 100644
--- a/target/linux/at91/image/sama5d4.mk
+++ b/target/linux/at91/image/sama5d4.mk
@@ -1,19 +0,0 @@
-
-define Device/default-nand
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
-endef
-
-define Device/at91-sama5d4_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
- KERNEL_SIZE := 6144k
- BLOCKSIZE := 256k
- PAGESIZE := 4096
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d4_xplained