summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm63xx/modules.mk')
-rw-r--r--target/linux/bcm63xx/modules.mk35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/bcm63xx/modules.mk b/target/linux/bcm63xx/modules.mk
deleted file mode 100644
index c329f3865a..0000000000
--- a/target/linux/bcm63xx/modules.mk
+++ /dev/null
@@ -1,35 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-only
-#
-# Copyright (C) 2010 OpenWrt.org
-
-define KernelPackage/pcmcia-bcm63xx
- SUBMENU:=$(PCMCIA_MENU)
- TITLE:=Broadcom BCM63xx PCMCIA support
- DEPENDS:=@TARGET_bcm63xx +kmod-pcmcia-rsrc
- KCONFIG:=CONFIG_PCMCIA_BCM63XX
- FILES:=$(LINUX_DIR)/drivers/pcmcia/bcm63xx_pcmcia.ko
- AUTOLOAD:=$(call AutoLoad,41,bcm63xx_pcmcia)
-endef
-
-define KernelPackage/pcmcia-bcm63xx/description
- Kernel support for PCMCIA/CardBus controller on the BCM63xx SoC
-endef
-
-$(eval $(call KernelPackage,pcmcia-bcm63xx))
-
-define KernelPackage/bcm63xx-udc
- SUBMENU:=$(USB_MENU)
- TITLE:=Broadcom BCM63xx UDC support
- DEPENDS:=@TARGET_bcm63xx +kmod-usb-gadget
- KCONFIG:=CONFIG_USB_BCM63XX_UDC
- FILES:= \
- $(LINUX_DIR)/drivers/usb/gadget/udc/bcm63xx_udc.ko
- AUTOLOAD:=$(call AutoLoad,51,bcm63xx_udc)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/bcm63xx-udc/description
- Kernel support for the USB gadget (device) controller on the BCM63xx SoC
-endef
-
-$(eval $(call KernelPackage,bcm63xx-udc))