summaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm63268.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bmips/image/bcm63268.mk')
-rw-r--r--target/linux/bmips/image/bcm63268.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm63268.mk b/target/linux/bmips/image/bcm63268.mk
index be3403174e..ed45bead7f 100644
--- a/target/linux/bmips/image/bcm63268.mk
+++ b/target/linux/bmips/image/bcm63268.mk
@@ -38,6 +38,26 @@ define Device/comtrend_vr-3032u
endef
TARGET_DEVICES += comtrend_vr-3032u
+define Device/sagem_fast-3864-op
+ $(Device/bcm63xx-nand)
+ DEVICE_VENDOR := Sagemcom
+ DEVICE_MODEL := F@ST 3864
+ DEVICE_VARIANT := OP
+ CHIP_ID := 63268
+ SOC := bcm63168
+ CFE_RAM_FILE := sagem,fast-3864-op/cferam.000
+ CFE_RAM_JFFS2_NAME := cferam.000
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ kmod-leds-bcm6328
+ CFE_WFI_FLASH_TYPE := 3
+ CFE_WFI_VERSION := 0x5732
+endef
+TARGET_DEVICES += sagem_fast-3864-op
+
define Device/sercomm_h500-s-lowi
$(Device/sercomm-nand)
DEVICE_VENDOR := Sercomm