summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 89cd134091..c3e7cbac48 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2012-2019 OpenWrt.org
# Copyright (C) 2016-2017 LEDE project
#
# This is free software, licensed under the GNU General Public License v2.
@@ -64,7 +64,10 @@ define Device/rpi
raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,model-b-rev2 \
raspberrypi,compute-module raspberrypi,compute-module-1 \
raspberrypi,model-zero raspberrypi,model-zero-w
- DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 kmod-brcmfmac wpad-basic
+ DEVICE_PACKAGES := \
+ brcmfmac-firmware-43430-sdio \
+ brcmfmac-firmware-43430-sdio-rpi-zero-w \
+ kmod-brcmfmac wpad-basic
endef
ifeq ($(SUBTARGET),bcm2708)
TARGET_DEVICES += rpi
@@ -78,7 +81,12 @@ define Device/rpi-2
raspberrypi,2-model-b \
raspberrypi,3-model-b raspberrypi,3-model-b-plus \
raspberrypi,3-compute-module raspberrypi,compute-module-3
- DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-firmware-43455-sdio brcmfmac-board-rpi2 brcmfmac-board-rpi3 kmod-brcmfmac wpad-basic
+ DEVICE_PACKAGES := \
+ brcmfmac-firmware-43430-sdio \
+ brcmfmac-firmware-43430-sdio-rpi-3b \
+ brcmfmac-firmware-43455-sdio brcmfmac-firmware-43455-clm_blob \
+ brcmfmac-firmware-43455-sdio-rpi-3b-plus \
+ kmod-brcmfmac wpad-basic
endef
ifeq ($(SUBTARGET),bcm2709)
TARGET_DEVICES += rpi-2
@@ -92,7 +100,12 @@ define Device/rpi-3
rpi-3-b rpi-3-b-plus \
raspberrypi,3-model-b raspberrypi,3-model-b-plus \
raspberrypi,3-compute-module raspberrypi,compute-module-3
- DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 brcmfmac-firmware-43455-sdio brcmfmac-board-rpi3 kmod-brcmfmac wpad-basic
+ DEVICE_PACKAGES := \
+ brcmfmac-firmware-43430-sdio \
+ brcmfmac-firmware-43430-sdio-rpi-3b \
+ brcmfmac-firmware-43455-sdio brcmfmac-firmware-43455-clm_blob \
+ brcmfmac-firmware-43455-sdio-rpi-3b-plus \
+ kmod-brcmfmac wpad-basic
endef
ifeq ($(SUBTARGET),bcm2710)
TARGET_DEVICES += rpi-3