summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 4a2ca8d68e..60e8654ad3 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -184,6 +184,21 @@ define Device/iom_ix2-200
endef
TARGET_DEVICES += iom_ix2-200
+define Device/iptime_nas1
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := NAS1
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 \
+ kmod-gpio-button-hotplug kmod-gpio-pca953x kmod-hwmon-drivetemp \
+ kmod-hwmon-gpiofan kmod-usb-ledtrig-usbport -uboot-envtools
+ KERNEL := $$(KERNEL) | iptime-naspkg nas1
+ BLOCKSIZE := 256k
+ IMAGE_SIZE := 15872k
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
+ check-size | append-metadata
+endef
+TARGET_DEVICES += iptime_nas1
+
define Device/linksys
DEVICE_VENDOR := Linksys
DEVICE_PACKAGES := kmod-mwl8k wpad-basic-wolfssl kmod-gpio-button-hotplug