summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa9.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image/cortexa9.mk')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 27f41c58a8..3234d62cd9 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -16,6 +16,23 @@ define Build/fortigate-header
mv $@.new $@
endef
+define Build/seil-header
+ ( \
+ data_size_crc="$$(gzip -c $@ | tail -c8 | \
+ od -An -tx8 --endian little | tr -d ' \n')"; \
+ printf "SEIL2015"; \
+ printf "$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)" | \
+ dd bs=80 count=1 conv=sync 2>/dev/null; \
+ printf "$$(echo $${data_size_crc:8:8} | sed 's/../\\x&/g')"; \
+ printf "\x00\x00\x00\x01\x00\x00\x00\x09\x00\x00\x00\x63"; \
+ printf "$(REVISION)" | dd bs=32 count=1 conv=sync 2>/dev/null; \
+ printf "\x00\x00\x00\x00"; \
+ printf "$$(echo $${data_size_crc:0:8} | sed 's/../\\x&/g')"; \
+ cat $@; \
+ ) > $@.new
+ mv $@.new $@
+endef
+
define Device/dsa-migration
DEVICE_COMPAT_VERSION := 1.1
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
@@ -134,6 +151,20 @@ define Device/globalscale_mirabox
endef
TARGET_DEVICES += globalscale_mirabox
+define Device/iij_sa-w2
+ DEVICE_VENDOR := IIJ
+ DEVICE_MODEL := SA-W2
+ SOC := armada-380
+ KERNEL := kernel-bin | append-dtb | seil-header
+ DEVICE_DTS := armada-380-iij-sa-w2
+ IMAGE_SIZE := 15360k
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | \
+ append-rootfs | pad-rootfs | check-size | append-metadata
+ DEVICE_PACKAGES := kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
+ wpad-basic-mbedtls
+endef
+TARGET_DEVICES += iij_sa-w2
+
define Device/iptime_nas1dual
DEVICE_VENDOR := ipTIME
DEVICE_MODEL := NAS1dual