summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile1
-rw-r--r--target/linux/mvebu/image/armada-macchiatobin.bootscript10
-rw-r--r--target/linux/mvebu/image/cortex-a72.mk16
3 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 4f6d8f529e..be01623e86 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -125,5 +125,6 @@ endef
include cortex-a9.mk
include cortex-a53.mk
+include cortex-a72.mk
$(eval $(call BuildImage))
diff --git a/target/linux/mvebu/image/armada-macchiatobin.bootscript b/target/linux/mvebu/image/armada-macchiatobin.bootscript
new file mode 100644
index 0000000000..ae9fdca92d
--- /dev/null
+++ b/target/linux/mvebu/image/armada-macchiatobin.bootscript
@@ -0,0 +1,10 @@
+setenv bootargs "root=PARTUUID=@ROOT@-02 rw rootwait"
+
+if test -n "${console}"; then
+ setenv bootargs "${bootargs} ${console}"
+fi
+
+load mmc 1:1 ${fdt_addr} armada-8040-mcbin.dtb
+load mmc 1:1 ${kernel_addr} Image
+
+booti ${kernel_addr} - ${fdt_addr}
diff --git a/target/linux/mvebu/image/cortex-a72.mk b/target/linux/mvebu/image/cortex-a72.mk
new file mode 100644
index 0000000000..ac9cb50a85
--- /dev/null
+++ b/target/linux/mvebu/image/cortex-a72.mk
@@ -0,0 +1,16 @@
+ifeq ($(SUBTARGET),cortexa72)
+
+define Device/armada-macchiatobin
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+ DEVICE_TITLE := MACCHIATObin (SolidRun Armada 8040 Community Board)
+ DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-mmc
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+ DEVICE_DTS := armada-8040-mcbin
+ DTS_DIR := $(DTS_DIR)/marvell
+ SUPPORTED_DEVICES := marvell,armada8040-mcbin
+endef
+TARGET_DEVICES += armada-macchiatobin
+
+endif