summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk37
1 files changed, 28 insertions, 9 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e97d2315f1..0315822c0b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -220,6 +220,18 @@ define Device/buffalo_wsr-600dhp
endef
TARGET_DEVICES += buffalo_wsr-600dhp
+define Device/dlink_dir-8xx-a1
+ IMAGE_SIZE := 16000k
+ DEVICE_VENDOR := D-Link
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+ KERNEL_INITRAMFS := $$(KERNEL) | uimage-padhdr 96
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | uimage-padhdr 96 |\
+ pad-rootfs | append-metadata | check-size
+ IMAGE/factory.bin := append-kernel | append-rootfs | uimage-padhdr 96 |\
+ check-size
+endef
+
define Device/dlink_dir-860l-b1
$(Device/seama)
BLOCKSIZE := 64k
@@ -236,21 +248,28 @@ define Device/dlink_dir-860l-b1
endef
TARGET_DEVICES += dlink_dir-860l-b1
+define Device/dlink_dir-867-a1
+ $(Device/dlink_dir-8xx-a1)
+ DEVICE_MODEL := DIR-867
+ DEVICE_VARIANT := A1
+endef
+TARGET_DEVICES += dlink_dir-867-a1
+
define Device/dlink_dir-878-a1
- IMAGE_SIZE := 16000k
- DEVICE_VENDOR := D-Link
+ $(Device/dlink_dir-8xx-a1)
DEVICE_MODEL := DIR-878
DEVICE_VARIANT := A1
- DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
- KERNEL_INITRAMFS := $$(KERNEL) | uimage-padhdr 96
- IMAGES += factory.bin
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | uimage-padhdr 96 |\
- pad-rootfs | append-metadata | check-size
- IMAGE/factory.bin := append-kernel | append-rootfs | uimage-padhdr 96 |\
- check-size
endef
TARGET_DEVICES += dlink_dir-878-a1
+define Device/dlink_dir-882-a1
+ $(Device/dlink_dir-8xx-a1)
+ DEVICE_MODEL := DIR-882
+ DEVICE_VARIANT := A1
+ DEVICE_PACKAGES += kmod-usb3 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += dlink_dir-882-a1
+
define Device/d-team_newifi-d2
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k