summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_tplink_archer-a6-v3.dts181
-rw-r--r--target/linux/ramips/dts/mt7621_tplink_archer-c6-v3.dts9
-rw-r--r--target/linux/ramips/dts/mt7621_tplink_archer-x6-v3.dtsi185
-rw-r--r--target/linux/ramips/image/mt7621.mk13
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/01_leds1
5 files changed, 209 insertions, 180 deletions
diff --git a/target/linux/ramips/dts/mt7621_tplink_archer-a6-v3.dts b/target/linux/ramips/dts/mt7621_tplink_archer-a6-v3.dts
index 46cb365da7..01fea5bde5 100644
--- a/target/linux/ramips/dts/mt7621_tplink_archer-a6-v3.dts
+++ b/target/linux/ramips/dts/mt7621_tplink_archer-a6-v3.dts
@@ -1,188 +1,9 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "mt7621_tplink_archer-x6-v3.dtsi"
/ {
compatible = "tplink,archer-a6-v3", "mediatek,mt7621-soc";
model = "TP-Link Archer A6 v3";
- aliases {
- label-mac-device = &gmac0;
- led-boot = &led_power;
- led-failsafe = &led_power;
- led-running = &led_power;
- led-upgrade = &led_power;
- };
-
- chosen {
- bootargs = "console=ttyS0,115200n8";
- };
-
- keys {
- compatible = "gpio-keys";
-
- wps {
- label = "wps";
- gpios = <&gpio 28 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- linux,code = <KEY_WPS_BUTTON>;
- };
-
- reset {
- label = "reset";
- gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- linux,code = <KEY_RESTART>;
- };
- };
-
- leds {
- compatible = "gpio-leds";
-
- led_power: power {
- label = "green:power";
- gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
- };
-
- wan_orange {
- label = "orange:wan";
- gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
- };
-
- lan {
- label = "green:lan";
- gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
- };
-
- wifi5g {
- label = "green:wifi5g";
- gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
- linux,default-trigger = "phy1tpt";
- };
-
- wifi2g {
- label = "green:wifi2g";
- gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
- linux,default-trigger = "phy0tpt";
- };
-
- wan_green {
- label = "green:wan";
- gpios = <&gpio 45 GPIO_ACTIVE_LOW>;
- };
- };
-};
-
-&spi0 {
- status = "okay";
-
- flash@0 {
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <40000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0 0x40000>;
- read-only;
- };
-
- partition@40000 {
- label = "firmware";
- compatible = "denx,uimage";
- reg = <0x40000 0xf60000>;
- };
-
- config: partition@fa0000 {
- label = "config";
- reg = <0xfa0000 0x50000>;
- read-only;
- };
-
- radio: partition@ff0000 {
- label = "radio";
- reg = <0xff0000 0x10000>;
- read-only;
- };
- };
- };
-};
-
-&state_default {
- gpio {
- groups = "i2c", "uart2", "uart3", "jtag", "wdt";
- function = "gpio";
- };
-};
-
-&ethernet {
- pinctrl-names = "default";
- pinctrl-0 = <&rgmii1_pins &mdio_pins>;
-};
-
-&pcie {
- status = "okay";
-};
-
-&pcie0 {
- wifi@0,0 {
- compatible = "mediatek,mt76";
- reg = <0x0000 0 0 0 0>;
- mediatek,mtd-eeprom = <&radio 0x0>;
- mtd-mac-address = <&config 0x8>;
- mtd-mac-address-increment = <1>;
- ieee80211-freq-limit = <2400000 2500000>;
- };
-};
-
-&pcie1 {
- wifi@0,0 {
- compatible = "mediatek,mt76";
- reg = <0x0000 0 0 0 0>;
- mediatek,mtd-eeprom = <&radio 0x8000>;
- mtd-mac-address = <&config 0x8>;
- mtd-mac-address-increment = <2>;
- ieee80211-freq-limit = <5000000 6000000>;
- };
-};
-
-&gmac0 {
- mtd-mac-address = <&config 0x8>;
-};
-
-&switch0 {
- ports {
- port@0 {
- status = "okay";
- label = "wan";
- };
-
- port@1 {
- status = "okay";
- label = "lan1";
- };
-
- port@2 {
- status = "okay";
- label = "lan2";
- };
-
- port@3 {
- status = "okay";
- label = "lan3";
- };
-
- port@4 {
- status = "okay";
- label = "lan4";
- };
- };
};
diff --git a/target/linux/ramips/dts/mt7621_tplink_archer-c6-v3.dts b/target/linux/ramips/dts/mt7621_tplink_archer-c6-v3.dts
new file mode 100644
index 0000000000..07d808ca20
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_tplink_archer-c6-v3.dts
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_tplink_archer-x6-v3.dtsi"
+
+/ {
+ compatible = "tplink,archer-c6-v3", "mediatek,mt7621-soc";
+ model = "TP-Link Archer C6 v3";
+
+};
diff --git a/target/linux/ramips/dts/mt7621_tplink_archer-x6-v3.dtsi b/target/linux/ramips/dts/mt7621_tplink_archer-x6-v3.dtsi
new file mode 100644
index 0000000000..76d9908fb9
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_tplink_archer-x6-v3.dtsi
@@ -0,0 +1,185 @@
+// SPDX-License-Identifier: GPL-2.0-only
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ aliases {
+ label-mac-device = &gmac0;
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200n8";
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 28 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "green:power";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ };
+
+ wan_orange {
+ label = "orange:wan";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ };
+
+ lan {
+ label = "green:lan";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi5g {
+ label = "green:wifi5g";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ wifi2g {
+ label = "green:wifi2g";
+ gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wan_green {
+ label = "green:wan";
+ gpios = <&gpio 45 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x40000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "firmware";
+ compatible = "denx,uimage";
+ reg = <0x40000 0xf60000>;
+ };
+
+ config: partition@fa0000 {
+ label = "config";
+ reg = <0xfa0000 0x50000>;
+ read-only;
+ };
+
+ radio: partition@ff0000 {
+ label = "radio";
+ reg = <0xff0000 0x10000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "i2c", "uart2", "uart3", "jtag", "wdt";
+ function = "gpio";
+ };
+};
+
+&ethernet {
+ pinctrl-names = "default";
+ pinctrl-0 = <&rgmii1_pins &mdio_pins>;
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&radio 0x0>;
+ mtd-mac-address = <&config 0x8>;
+ mtd-mac-address-increment = <1>;
+ ieee80211-freq-limit = <2400000 2500000>;
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&radio 0x8000>;
+ mtd-mac-address = <&config 0x8>;
+ mtd-mac-address-increment = <2>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&gmac0 {
+ mtd-mac-address = <&config 0x8>;
+};
+
+&switch0 {
+ ports {
+ port@0 {
+ status = "okay";
+ label = "wan";
+ };
+
+ port@1 {
+ status = "okay";
+ label = "lan1";
+ };
+
+ port@2 {
+ status = "okay";
+ label = "lan2";
+ };
+
+ port@3 {
+ status = "okay";
+ label = "lan3";
+ };
+
+ port@4 {
+ status = "okay";
+ label = "lan4";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index efeac698b1..ee5ebaa8b2 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1244,6 +1244,19 @@ define Device/tplink_archer-a6-v3
endef
TARGET_DEVICES += tplink_archer-a6-v3
+define Device/tplink_archer-c6-v3
+ $(Device/dsa-migration)
+ $(Device/tplink-safeloader)
+ DEVICE_MODEL := Archer C6
+ DEVICE_VARIANT := V3
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e \
+ kmod-mt7663-firmware-ap kmod-mt7663-firmware-sta
+ TPLINK_BOARD_ID := ARCHER-C6-V3
+ KERNEL := $(KERNEL_DTB) | uImage lzma
+ IMAGE_SIZE := 15744k
+endef
+TARGET_DEVICES += tplink_archer-c6-v3
+
define Device/tplink_archer-c6u-v1
$(Device/dsa-migration)
$(Device/tplink-safeloader)
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
index 5322bc9db0..c04dae4f0d 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
@@ -90,6 +90,7 @@ netgear,r6800)
ucidef_set_led_netdev "lan4" "LAN4" "white:lan4" "lan4"
;;
tplink,archer-a6-v3|\
+tplink,archer-c6-v3|\
tplink,archer-c6u-v1)
ucidef_set_led_netdev "lan" "LAN" "green:lan" "br-lan"
ucidef_set_led_netdev "wan" "WAN" "green:wan" "wan"