summaryrefslogtreecommitdiffstats
path: root/tools/e2fsprogs
diff options
context:
space:
mode:
Diffstat (limited to 'tools/e2fsprogs')
-rw-r--r--tools/e2fsprogs/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/e2fsprogs/Makefile b/tools/e2fsprogs/Makefile
index fec6d83454..f11ce52ca0 100644
--- a/tools/e2fsprogs/Makefile
+++ b/tools/e2fsprogs/Makefile
@@ -20,6 +20,9 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+ifneq ($(shell $(HOSTCC) --version | grep clang),)
+ HOST_CFLAGS += -D__GNUC_PREREQ\(...\)=0
+endif
HOST_CFLAGS += $(FPIC)
HOST_CONFIGURE_ARGS += \