summaryrefslogtreecommitdiffstats
path: root/tools/fakeroot
diff options
context:
space:
mode:
Diffstat (limited to 'tools/fakeroot')
-rw-r--r--tools/fakeroot/Makefile4
-rw-r--r--tools/fakeroot/patches/200-disable-doc.patch2
-rw-r--r--tools/fakeroot/patches/300-time64-hack.patch11
-rw-r--r--tools/fakeroot/patches/400-alpine-libc.musl-fix.patch11
-rw-r--r--tools/fakeroot/patches/600-macOS.patch8
5 files changed, 18 insertions, 18 deletions
diff --git a/tools/fakeroot/Makefile b/tools/fakeroot/Makefile
index efd9227d1a..22b2c8f24f 100644
--- a/tools/fakeroot/Makefile
+++ b/tools/fakeroot/Makefile
@@ -5,12 +5,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=fakeroot
-PKG_VERSION:=1.29
+PKG_VERSION:=1.36
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
PKG_SOURCE_URL:=@DEBIAN/pool/main/f/fakeroot
-PKG_HASH:=8fbbafb780c9173e3ace4a04afbc1d900f337f3216883939f5c7db3431be7c20
+PKG_HASH:=7fe3cf3daf95ee93b47e568e85f4d341a1f9ae91766b4f9a9cdc29737dea4988
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
diff --git a/tools/fakeroot/patches/200-disable-doc.patch b/tools/fakeroot/patches/200-disable-doc.patch
index 29a3e39b2d..cceb6ccc26 100644
--- a/tools/fakeroot/patches/200-disable-doc.patch
+++ b/tools/fakeroot/patches/200-disable-doc.patch
@@ -6,5 +6,5 @@
-SUBDIRS=doc scripts test
+SUBDIRS=scripts test
- noinst_LTLIBRARIES = libcommunicate.la libmacosx.la
+ noinst_LTLIBRARIES = libcommunicate.la libmacosx.la libfakeroot_time64.la
libcommunicate_la_SOURCES = communicate.c
diff --git a/tools/fakeroot/patches/300-time64-hack.patch b/tools/fakeroot/patches/300-time64-hack.patch
new file mode 100644
index 0000000000..46132cdd3d
--- /dev/null
+++ b/tools/fakeroot/patches/300-time64-hack.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -390,7 +390,7 @@ dnl Digital Unix: stat
+ time64_hack=no
+ AH_TEMPLATE([TIME64_HACK], [time64 shuffle])
+ AC_MSG_CHECKING([if we need to cope with time64])
+-AC_EGREP_CPP([time64],[
++AC_EGREP_CPP([_*[a-z0-9]+_time64[^_]],[
+ #include <bits/wordsize.h>
+ #if __WORDSIZE == 32
+ #define __USE_TIME_BITS64 1
diff --git a/tools/fakeroot/patches/400-alpine-libc.musl-fix.patch b/tools/fakeroot/patches/400-alpine-libc.musl-fix.patch
index f740b120a1..5936034911 100644
--- a/tools/fakeroot/patches/400-alpine-libc.musl-fix.patch
+++ b/tools/fakeroot/patches/400-alpine-libc.musl-fix.patch
@@ -21,14 +21,3 @@ Error relocating openwrt/staging_dir/host/lib/libfakeroot.so: SEND_GET_XATTR: sy
#define SEND_GET_XATTR64(a,b,c) send_get_xattr64(a,b)
#endif
-@@ -142,8 +144,9 @@
-
- /* 10.10 uses id_t in getpriority/setpriority calls, so pretend
- id_t is used everywhere, just happens to be int on some OSes */
--#ifndef _ID_T
-+#if !defined(_ID_T) && !defined(__DEFINED_id_t)
- #define _ID_T
-+#define __DEFINED_id_t
- typedef int id_t;
- #endif
- #endif
diff --git a/tools/fakeroot/patches/600-macOS.patch b/tools/fakeroot/patches/600-macOS.patch
index 730367f07c..df4eb2d6c1 100644
--- a/tools/fakeroot/patches/600-macOS.patch
+++ b/tools/fakeroot/patches/600-macOS.patch
@@ -24,10 +24,10 @@
#include <spawn.h>
--- a/wrapfunc.inp
+++ b/wrapfunc.inp
-@@ -48,9 +48,11 @@ getattrlist$UNIX2003;int;(const char *pa
- #endif
+@@ -51,9 +51,11 @@ getattrlist$UNIX2003;int;(const char *pa
#endif
#if MAC_OS_X_VERSION_MIN_REQUIRED >= MAC_OS_X_VERSION_10_5
+ #include <spawn.h>
+#if !__DARWIN_ONLY_64_BIT_INO_T
lstat$INODE64;int;(const char *file_name, struct stat *buf);(file_name, buf)
stat$INODE64;int;(const char *file_name, struct stat *buf);(file_name, buf)
@@ -36,7 +36,7 @@
posix_spawn;int;(pid_t * __restrict pid, const char * __restrict path, const posix_spawn_file_actions_t *file_actions, const posix_spawnattr_t * __restrict attrp, char *const argv[ __restrict], char *const envp[ __restrict]);(pid, path, file_actions, attrp, argv, envp)
posix_spawnp;int;(pid_t * __restrict pid, const char * __restrict path, const posix_spawn_file_actions_t *file_actions, const posix_spawnattr_t * __restrict attrp, char *const argv[ __restrict], char *const envp[ __restrict]);(pid, path, file_actions, attrp, argv, envp)
#endif
-@@ -229,7 +231,7 @@ facl;int;(int fd, int cmd, int cnt, void
+@@ -235,7 +237,7 @@ facl;int;(int fd, int cmd, int cnt, void
#ifdef HAVE_FTS_READ
fts_read;FTSENT *;(FTS *ftsp);(ftsp)
#ifdef __APPLE__
@@ -45,7 +45,7 @@
fts_read$INODE64;FTSENT *;(FTS *ftsp);(ftsp)
#endif
#endif /* ifdef __APPLE__ */
-@@ -237,7 +239,7 @@ fts_read$INODE64;FTSENT *;(FTS *ftsp);(f
+@@ -243,7 +245,7 @@ fts_read$INODE64;FTSENT *;(FTS *ftsp);(f
#ifdef HAVE_FTS_CHILDREN
fts_children;FTSENT *;(FTS *ftsp, int options);(ftsp, options)
#ifdef __APPLE__