summaryrefslogtreecommitdiffstats
path: root/tools/padjffs2
diff options
context:
space:
mode:
Diffstat (limited to 'tools/padjffs2')
-rw-r--r--tools/padjffs2/Makefile6
-rw-r--r--tools/padjffs2/src/Makefile2
2 files changed, 6 insertions, 2 deletions
diff --git a/tools/padjffs2/Makefile b/tools/padjffs2/Makefile
index a949ac0628..3f033c0c2b 100644
--- a/tools/padjffs2/Makefile
+++ b/tools/padjffs2/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -18,6 +18,10 @@ define Host/Prepare
find $(HOST_BUILD_DIR) -name .svn | $(XARGS) rm -rf
endef
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) LDFLAGS="-static"
+endef
+
define Host/Configure
endef
diff --git a/tools/padjffs2/src/Makefile b/tools/padjffs2/src/Makefile
index fe1a7aa628..45da8e5dbc 100644
--- a/tools/padjffs2/src/Makefile
+++ b/tools/padjffs2/src/Makefile
@@ -9,7 +9,7 @@ all: padjffs2
$(CC) $(CFLAGS) $(WFLAGS) -c -o $@ $<
padjffs2: $(padjffs2-objs)
- $(CC) -o $@ $(padjffs2-objs)
+ $(CC) $(LDFLAGS) -o $@ $(padjffs2-objs)
clean:
rm -f padjffs2 *.o