summaryrefslogtreecommitdiffstats
path: root/tools/sstrip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/sstrip/Makefile')
-rw-r--r--tools/sstrip/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/sstrip/Makefile b/tools/sstrip/Makefile
new file mode 100644
index 0000000000..4e409e0d8d
--- /dev/null
+++ b/tools/sstrip/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/sstrip
+
+OS:=$(shell uname)
+ifeq ($(HOST_OS),Darwin)
+ CFLAGS += -I./include
+endif
+
+define Build/Compile
+ $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
+endef
+
+define Build/Install
+ mkdir -p $(STAGING_DIR)/bin
+ $(CP) $(PKG_BUILD_DIR)/sstrip $(STAGING_DIR)/bin/
+endef
+
+define Build/Clean
+ rm -f $(STAGING_DIR)/bin/sstrip
+endef
+
+$(eval $(call HostBuild))