summaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjk <jk@vin.ovh>2021-06-21 14:33:24 -0500
committerjk <jk@vin.ovh>2021-06-21 14:33:24 -0500
commite33c3c9ffb07a77aa9004d6d8b1228fe1b2344a1 (patch)
tree40f6217a5ad5df37788069baa796f0b63201102b /PKGBUILD
parent4e5bc82a42277ef918ce4986a544eb54cc9dcf10 (diff)
downloadungoogled-chromium-e33c3c9ffb07a77aa9004d6d8b1228fe1b2344a1.tar.gz
ungoogled-chromium-e33c3c9ffb07a77aa9004d6d8b1228fe1b2344a1.tar.bz2
ungoogled-chromium-e33c3c9ffb07a77aa9004d6d8b1228fe1b2344a1.zip
upgpkg: ungoogled-chromium 91.0.4472.114-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5e615a..c01be10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium
-pkgver=91.0.4472.101
+pkgver=91.0.4472.114
pkgrel=1
_launcher_ver=7
_gcc_patchset=5
@@ -26,7 +26,7 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
- 'java-runtime-headless' 'python2' 'python2-setuptools')
+ 'java-runtime-headless' 'python2')
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
@@ -38,15 +38,17 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
fix-crash-in-ThemeService.patch
unbundle-use-char16_t-as-UCHAR_TYPE.patch
+ make-dom-distiller-protoc-plugin-call-py2.7.patch
extend-enable-accelerated-video-decode-flag.patch
sql-make-VirtualCursor-standard-layout-type.patch
chromium-glibc-2.33.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('78146192aaae7771d9130c2828e1081d940da32af3aadcb73578521683307eb4'
+sha256sums=('c1c7fe783f3250978503d4bd53144039bd818de8a6e89de493f27dd5168f7e71'
'86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
'171525009003a9ed1182cfcb6f407d7169d9a731a474304e263029376719f55a'
'3cfe46e181cb9d337c454b5b5adbf5297052f29cd617cdee4380eeb1943825d8'
'59a59a60a08b335fe8647fdf0f9d2288d236ebf2cc9626396d0c4d032fd2b25d'
+ '76ceebd14c9a6f1ea6a05b1613e64d1e2aca595e0f0b3e9497e3eeee33ed756c'
'66db9132d6f5e06aa26e5de0924f814224a76a9bdf4b61afce161fb1d7643b22'
'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
@@ -56,7 +58,7 @@ source=(${source[@]}
chromium-drirc-disable-10bpc-color-configs.conf
wayland-egl.patch)
sha256sums=(${sha256sums[@]}
- '3826409802280c7a565db1c532d6467976f3b3ec59b9259f432615b67dc046ad'
+ '318b890f0d422c573f285a33b6f74ce8446c7aa16677a2236250827defca66e5'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
'34d08ea93cb4762cb33c7cffe931358008af32265fc720f2762f0179c3973574')
@@ -110,6 +112,7 @@ prepare() {
# Upstream fixes
#patch -Np1 -i ../fix-crash-in-ThemeService.patch
patch -Np1 -i ../unbundle-use-char16_t-as-UCHAR_TYPE.patch
+ patch -Np1 -i ../make-dom-distiller-protoc-plugin-call-py2.7.patch
patch -Np1 -i ../extend-enable-accelerated-video-decode-flag.patch
# https://chromium-review.googlesource.com/c/chromium/src/+/2862724
@@ -132,9 +135,6 @@ prepare() {
python "$_utils/domain_substitution.py" apply -r "$_ungoogled_repo/domain_regex.list" \
-f "$_ungoogled_repo/domain_substitution.list" -c domainsubcache.tar.gz ./
- # Force script incompatible with Python 3 to use /usr/bin/python2
- sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
-
# Link to system tools required by the build
mkdir -p third_party/node/linux/node-linux-x64/bin
ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/