summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.de>2021-09-27 15:12:26 +0200
committerNico Huber <nico.h@gmx.de>2021-09-28 22:00:41 +0000
commit29ff205e6f10895cd6c53678398b962eb18694d2 (patch)
tree5c673f6f068496f95b5b23dca283fd2d83d68e44 /meson.build
parent5a8b0773dd777b4ca60dbcc30168dc3cb5945a1a (diff)
downloadflashrom-29ff205e6f10895cd6c53678398b962eb18694d2.tar.gz
flashrom-29ff205e6f10895cd6c53678398b962eb18694d2.tar.bz2
flashrom-29ff205e6f10895cd6c53678398b962eb18694d2.zip
custom_baud: move Linux specific code into own file
Handle system specific code in an own file like i2c_helper_linux.c. The build system decides when to build it. Change-Id: I0744e769dcc6000483e7256105903a87e927ee77 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.de> Reviewed-on: https://review.coreboot.org/c/flashrom/+/57990 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index fcb11c63d..1a36df887 100644
--- a/meson.build
+++ b/meson.build
@@ -323,8 +323,12 @@ endif
# raw serial IO
if need_serial
- srcs += 'custom_baud.c'
srcs += 'serial.c'
+ if host_machine.system() == 'linux'
+ srcs += 'custom_baud_linux.c'
+ else
+ srcs += 'custom_baud.c'
+ endif
endif
prefix = get_option('prefix')