summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index fcb11c63d..1a36df887 100644
--- a/meson.build
+++ b/meson.build
@@ -323,8 +323,12 @@ endif
# raw serial IO
if need_serial
- srcs += 'custom_baud.c'
srcs += 'serial.c'
+ if host_machine.system() == 'linux'
+ srcs += 'custom_baud_linux.c'
+ else
+ srcs += 'custom_baud.c'
+ endif
endif
prefix = get_option('prefix')