summaryrefslogtreecommitdiffstats
path: root/drivers/staging/hv/vmbus.c
Commit message (Collapse)AuthorAgeFilesLines
* Staging: hv: remove vmbus.cGreg Kroah-Hartman2010-12-021-236/+0
| | | | | | | | | | Merge the functions into vmbus_drv.c as there's no need to have them separate anymore. It will also make unwinding some of the function and pointer mess easier, as well as making functions static in the future. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: rename the vmbus to "hyperv"Greg Kroah-Hartman2010-12-021-1/+1
| | | | | | | | | This changes the name of the bus in sysfs from "vmbus" to "hyperv" which is the name it should show (vmbus is way to generic). Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove struct vmbus_driverGreg Kroah-Hartman2010-12-021-8/+7
| | | | | | | | | It's only a wrapper for the struct hv_driver structure, so just use that instead, as there are no other fields left in it at the moment. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove OnChildDeviceAdd vmbus_driver callbackGreg Kroah-Hartman2010-12-021-3/+1
| | | | | | | | It's only ever set to one function, so just call that function instead. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove GetChannelOffers vmbus_driver callbackGreg Kroah-Hartman2010-12-021-9/+0
| | | | | | | | | | | It's only ever set to one function, so just call that function instead. Actually, that wrapper function only ever called vmbus_request_offers() so just call that function instead, no need for a do-nothing intermediate step here. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove OnEventDpc vmbus_driver callbackGreg Kroah-Hartman2010-12-021-3/+2
| | | | | | | | It's only ever set to one function, so just call that function instead. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove OnMsgDpc vmbus_driver callbackGreg Kroah-Hartman2010-12-021-3/+2
| | | | | | | | It's only ever set to one function, so just call that function instead. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove OnIsr vmbus_driver callbackGreg Kroah-Hartman2010-12-021-3/+2
| | | | | | | | It's only ever set to one function, so just call that function instead. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove OnChildDeviceRemove vmbus_driver callbackGreg Kroah-Hartman2010-12-021-10/+0
| | | | | | | | It's only ever set to one function, so just call that function instead. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove OnChildDeviceCreate vmbus_driver callbackGreg Kroah-Hartman2010-12-021-13/+0
| | | | | | | | It's only ever set to one function, so just call that function instead. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* staging: hv: Convert camel cased functions in hv.c to lower casesHaiyang Zhang2010-11-091-4/+4
| | | | | | | | staging: hv: Convert camel cased functions in hv.c to lower cases Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* staging: hv: Convert camel cased struct fields in hv.h to lower casesHaiyang Zhang2010-11-091-3/+3
| | | | | | | | staging: hv: Convert camel cased struct fields in hv.h to lower cases Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* staging: hv: Convert camel cased struct fields in hv_api.h to lower casesHaiyang Zhang2010-11-091-9/+9
| | | | | | | | staging: hv: Convert camel cased struct fields in hv_api.h to lower cases Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: rename context to channel in struct hv_deviceGreg Kroah-Hartman2010-10-211-2/+2
| | | | | | | | | | | | | | As it really is a channel, not a "context" name it so. This also entailed making a few more functions typesafe as they were sending a struct vmbus_channel pointer as a void pointer. There are still a few more that need to be converted (the osd callbacks are one), but this is good for now. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove GetChannelInfo from struct vmbus_driverGreg Kroah-Hartman2010-10-201-1/+0
| | | | | | | | | It was only set to one value, so just make the call to get_channel_info() directly. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove VmbusGetChannelInfoGreg Kroah-Hartman2010-10-201-10/+1
| | | | | | | | | It's not needed, make the function pointer point to get_channel_info() instead. Cc: Haiyang Zhang <haiyangz@microsoft.com> Cc: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* staging: hv: Convert camel cased functions in channel_mgmt.c to lower caseHaiyang Zhang2010-10-151-3/+3
| | | | | | | | Convert camel cased functions in channel_mgmt.c to lower case Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* staging: hv: Convert camel cased function names in channel_interface.c to ↵Haiyang Zhang2010-10-151-1/+1
| | | | | | | | | | lower cases Convert camel cased function names in channel_interface.c to lower cases Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* staging: hv: Remove camel cases of vmbus packet buffer structuresHaiyang Zhang2010-09-201-3/+3
| | | | | | | | | | | Remove camel cases of vmbus packet buffer structures Remove camel cases of: struct VMBUS_CHANNEL_PACKET_PAGE_BUFFER struct VMBUS_CHANNEL_PACKET_MULITPAGE_BUFFER Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* staging: hv: Convert vmbus driver interface function pointer table to constantHaiyang Zhang2010-09-141-9/+0
| | | | | | | | | | | | | | | | | | Convert vmbus driver interface function pointer table to constant The vmbus interface functions are assigned to a constant - vmbus_ops. Because the vmbus interface function pointer table is converted to a constant variable -- vmbus_ops, the function GetChannelInterface(), VmbusGetChannelInterface() and pointer GetChannelInterface are no longer in use. The deprecated function's work is done by the initialization of the newly added constant variable vmbus_ops. I created the new constant variable vmbus_ops and removed the deprecated function pointer GetChannelInterface in one patch. Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Hank Janssen <hjanssen@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove DPRINT_EXIT macroGreg Kroah-Hartman2010-07-221-9/+0
| | | | | | | | | No need for it, use the built-in kernel function tracing instead if you really need something like this. Cc: Hank Janssen <hjanssen@microsoft.com> Cc: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: remove DPRINT_ENTER macroGreg Kroah-Hartman2010-07-221-9/+0
| | | | | | | | | We have ftrace to look at function traces if its really needed. Don't roll custom macros for this. Cc: Hank Janssen <hjanssen@microsoft.com> Cc: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: Use kmemdupJulia Lawall2010-05-171-2/+1
| | | | | | | | | | | | | | | | | | | | | | | Use kmemdup when some other buffer is immediately copied into the allocated region. A simplified version of the semantic patch that makes this change is as follows: (http://coccinelle.lip6.fr/) // <smpl> @@ expression from,to,size,flag; statement S; @@ - to = \(kmalloc\|kzalloc\)(size,flag); + to = kmemdup(from,size,flag); if (to==NULL || ...) S - memcpy(to, from, size); // </smpl> Signed-off-by: Julia Lawall <julia@diku.dk> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: rename VersionInfo.h to version_info.hGreg Kroah-Hartman2010-05-111-1/+1
| | | | | | | | The great renaming of the hv code is now complete. Cc: Hank Janssen <hjanssen@microsoft.com> Cc: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: rename VmbusPrivate.h to vmbus_private.hGreg Kroah-Hartman2010-05-111-1/+1
| | | | | | Cc: Hank Janssen <hjanssen@microsoft.com> Cc: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
* Staging: hv: rename Vmbus.c to vmbus.cGreg Kroah-Hartman2010-05-111-0/+312
Cc: Hank Janssen <hjanssen@microsoft.com> Cc: Haiyang Zhang <haiyangz@microsoft.com> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>