summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2024-04-18 16:49:27 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2024-04-19 18:32:42 +0200
commit38dc19828d56bfe3457440aa85126182a8c6c0fb (patch)
tree0e365b5c560950fcabc334156e46fc0b506ac8ba
parenta33989469156043df915e1274e9d3a5874150ed7 (diff)
downloadopenwrt-38dc19828d56bfe3457440aa85126182a8c6c0fb.tar.gz
openwrt-38dc19828d56bfe3457440aa85126182a8c6c0fb.tar.bz2
openwrt-38dc19828d56bfe3457440aa85126182a8c6c0fb.zip
mxs: adjust DTS path for 6.6
For the ARM arch on 6.6, DTS files are moved into their vendor directories, mimicking arm64. Reflect this in the image Makefile. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
-rw-r--r--target/linux/mxs/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index f1847dec1e..585211dc0b 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -39,6 +39,9 @@ define Device/Default
KERNEL_NAME := zImage
KERNEL := kernel-bin | uImage none
IMAGES := sdcard.img.gz
+ifneq ($(KERNEL),6.1)
+ DTS_DIR := $(DTS_DIR)/nxp/mxs
+endif
DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
endef