summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/mxs/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index f1847dec1e..585211dc0b 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -39,6 +39,9 @@ define Device/Default
KERNEL_NAME := zImage
KERNEL := kernel-bin | uImage none
IMAGES := sdcard.img.gz
+ifneq ($(KERNEL),6.1)
+ DTS_DIR := $(DTS_DIR)/nxp/mxs
+endif
DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
endef