summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2021-03-01 13:27:17 +0100
committerPetr Štetiar <ynezz@true.cz>2021-03-03 22:51:39 +0100
commitac7034cd12c2018338d58eb1e1911755912f33b0 (patch)
tree1f9c3e40c9ce085d7d3d6ed278d8a8eca19e00fd
parent5e0b9dbe8afa723dd7de2d7d1eca3c49a3e0792f (diff)
downloadopenwrt-ac7034cd12c2018338d58eb1e1911755912f33b0.tar.gz
openwrt-ac7034cd12c2018338d58eb1e1911755912f33b0.tar.bz2
openwrt-ac7034cd12c2018338d58eb1e1911755912f33b0.zip
build: make GCC version 6+ minimal host build requirement
Currently minimal GNU supported GCC version is 7 (from May 2, 2017), buildbots are using default GCC version 6 on Debian 9 (old stable), current Debian stable has GCC version 8.3.0. Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--README.md2
-rw-r--r--include/prereq-build.mk14
2 files changed, 8 insertions, 8 deletions
diff --git a/README.md b/README.md
index b30819205b..cb4b043655 100644
--- a/README.md
+++ b/README.md
@@ -25,7 +25,7 @@ the [Build System Setup](https://openwrt.org/docs/guide-developer/build-system/i
documentation.
```
-gcc binutils bzip2 flex python3 perl make4.1+ find grep diff unzip gawk getopt
+gcc-6+ binutils bzip2 flex python3 perl make4.1+ find grep diff unzip gawk getopt
subversion libz-dev libc-dev rsync
```
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index f88e853b52..8a6c4bb468 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -25,21 +25,21 @@ $(eval $(call TestHostCommand,proper-umask, \
ifndef IB
$(eval $(call SetupHostCommand,gcc, \
- Please install the GNU C Compiler (gcc) 4.8 or later, \
- $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
- gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+ Please install the GNU C Compiler (gcc) 6 or later, \
+ $(CC) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+ gcc -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
gcc --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-gcc, \
- \nPlease reinstall the GNU C Compiler (4.8 or later) - \
+ \nPlease reinstall the GNU C Compiler (6 or later) - \
it appears to be broken, \
echo 'int main(int argc, char **argv) { return 0; }' | \
gcc -x c -o $(TMP_DIR)/a.out -))
$(eval $(call SetupHostCommand,g++, \
- Please install the GNU C++ Compiler (g++) 4.8 or later, \
- $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
- g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+ Please install the GNU C++ Compiler (g++) 6 or later, \
+ $(CXX) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+ g++ -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
g++ --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-g++, \