summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-08-20 14:12:32 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-10 15:42:36 +0200
commit22b7bd6b1355baf7220136b6bd8277a321b70c39 (patch)
tree5be900833adbd4d1b0ef2449c5b28e6dabb7eca2 /Makefile
parentd02e887d7ceb25008fa70c42174207dfeb65b5f0 (diff)
downloadopenwrt-22b7bd6b1355baf7220136b6bd8277a321b70c39.tar.gz
openwrt-22b7bd6b1355baf7220136b6bd8277a321b70c39.tar.bz2
openwrt-22b7bd6b1355baf7220136b6bd8277a321b70c39.zip
Makefile: replace head call with grep's -m
head is not necessary here. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3ac110367d..bfb52c5ddd 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
world:
-DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' | head -n 1)
+DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' -m 1)
export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
ifneq ($(OPENWRT_BUILD),1)