summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-11-09 09:34:17 -0800
committerFelix Fietkau <nbd@nbd.name>2016-12-04 11:41:51 +0100
commitb9aab34eb4ddf935ee6296f587857e5a495cae0e (patch)
treed623db9a07a230285168c0ab47705a0a4219b175 /include/download.mk
parent832fb99da24ffe527e1ebd8363ea0d5a459dd594 (diff)
downloadopenwrt-b9aab34eb4ddf935ee6296f587857e5a495cae0e.tar.gz
openwrt-b9aab34eb4ddf935ee6296f587857e5a495cae0e.tar.bz2
openwrt-b9aab34eb4ddf935ee6296f587857e5a495cae0e.zip
include/download.mk: Allow specify DownloadMethod specific options
This is going to be used to migrate the hand rolled git clone for the kernel into using the git download method. The kernel uses custom options that we may have to pass down. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 2797e90364..9fbc3fb656 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -93,7 +93,7 @@ define DownloadMethod/git
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- git clone $(URL) $(SUBDIR) && \
+ git clone $(OPTS) $(URL) $(SUBDIR) && \
(cd $(SUBDIR) && git checkout $(VERSION) && \
git submodule update --init --recursive) && \
echo "Packing checkout..." && \
@@ -172,6 +172,7 @@ define Download/Defaults
MIRROR:=1
MIRROR_MD5SUM:=x
VERSION:=
+ OPTS:=
endef
define Download