summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 2797e90364..9fbc3fb656 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -93,7 +93,7 @@ define DownloadMethod/git
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- git clone $(URL) $(SUBDIR) && \
+ git clone $(OPTS) $(URL) $(SUBDIR) && \
(cd $(SUBDIR) && git checkout $(VERSION) && \
git submodule update --init --recursive) && \
echo "Packing checkout..." && \
@@ -172,6 +172,7 @@ define Download/Defaults
MIRROR:=1
MIRROR_MD5SUM:=x
VERSION:=
+ OPTS:=
endef
define Download