summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-19 12:41:59 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-19 13:30:22 +0100
commit5aa03e16a732e81a989a9605706dc8c6bb95d03f (patch)
tree878fdd7228d00d6fe967938817be02d5ac4feeb0 /include/host-build.mk
parentbc73a7fd98b2c2c20cc2a796d625e671ca00eccf (diff)
downloadopenwrt-5aa03e16a732e81a989a9605706dc8c6bb95d03f.tar.gz
openwrt-5aa03e16a732e81a989a9605706dc8c6bb95d03f.tar.bz2
openwrt-5aa03e16a732e81a989a9605706dc8c6bb95d03f.zip
build: disable CONFIG_AUTOREMOVE for packages/tools where QUILT is used
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index cf1203995c..6a335fcbc3 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -35,6 +35,8 @@ override MAKEFLAGS=
include $(INCLUDE_DIR)/quilt.mk
include $(INCLUDE_DIR)/autotools.mk
+_host_target:=$(if $(HOST_QUILT),,.)
+
Host/Patch:=$(Host/Patch/Default)
ifneq ($(strip $(HOST_UNPACK)),)
define Host/Prepare/Default
@@ -176,9 +178,9 @@ ifndef DUMP
)
endif
- .host-prepare: $(HOST_STAMP_PREPARED)
- .host-configure: $(HOST_STAMP_CONFIGURED)
- .host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
+ $(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
+ $(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
+ $(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
host-clean: FORCE
$(call Host/Clean)
$(call Host/Uninstall)