summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-07-14 04:25:36 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-07-30 19:04:36 +0200
commit4a28537e4c858888f918c1b6f1210964da2da160 (patch)
tree261b3ed3440160a206bb64a612c52e5dac2923e8 /include/image-commands.mk
parent603aaceb4288555e8e9ad6a559288ce1b2e1131d (diff)
downloadopenwrt-4a28537e4c858888f918c1b6f1210964da2da160.tar.gz
openwrt-4a28537e4c858888f918c1b6f1210964da2da160.tar.bz2
openwrt-4a28537e4c858888f918c1b6f1210964da2da160.zip
image-commands: fix generating out-of-tree DTO
Hack path so DTO generation works also for out-of-tree device tree sources which currently fail. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 402e3d71ed..6fe2890a1a 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -279,9 +279,11 @@ endef
define Build/fit
$(TOPDIR)/scripts/mkits.sh \
-D $(DEVICE_NAME) -o $@.its -k $@ \
- -C $(word 1,$(1)) $(if $(word 2,$(1)),\
- $(if $(DEVICE_DTS_OVERLAY),-d $(KERNEL_BUILD_DIR)/image-$$(basename $(word 2,$(1))),\
- -d $(word 2,$(1)))) \
+ -C $(word 1,$(1)) \
+ $(if $(word 2,$(1)),\
+ $(if $(findstring 11,$(if $(DEVICE_DTS_OVERLAY),1)$(if $(findstring $(KERNEL_BUILD_DIR)/image-,$(word 2,$(1))),,1)), \
+ -d $(KERNEL_BUILD_DIR)/image-$$(basename $(word 2,$(1))), \
+ -d $(word 2,$(1)))) \
$(if $(findstring with-rootfs,$(word 3,$(1))),-r $(IMAGE_ROOTFS)) \
$(if $(findstring with-initrd,$(word 3,$(1))), \
$(if $(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPARATE), \