summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-19 12:41:59 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-19 13:30:22 +0100
commit5aa03e16a732e81a989a9605706dc8c6bb95d03f (patch)
tree878fdd7228d00d6fe967938817be02d5ac4feeb0 /include/package-ipkg.mk
parentbc73a7fd98b2c2c20cc2a796d625e671ca00eccf (diff)
downloadopenwrt-5aa03e16a732e81a989a9605706dc8c6bb95d03f.tar.gz
openwrt-5aa03e16a732e81a989a9605706dc8c6bb95d03f.tar.bz2
openwrt-5aa03e16a732e81a989a9605706dc8c6bb95d03f.zip
build: disable CONFIG_AUTOREMOVE for packages/tools where QUILT is used
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 8a9c10f64b..d73d461537 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -106,7 +106,7 @@ ifeq ($(DUMP),)
ifdef do_install
ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
IPKGS += $(1)
- .compile: $$(IPKG_$(1)) $(PKG_INFO_DIR)/$(1).provides $(PKG_BUILD_DIR)/.pkgdir/$(1).installed
+ $(_pkg_target)compile: $$(IPKG_$(1)) $(PKG_INFO_DIR)/$(1).provides $(PKG_BUILD_DIR)/.pkgdir/$(1).installed
compile: $(STAGING_DIR_ROOT)/stamp/.$(1)_installed
else
$(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))