summaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2021-06-14 14:58:37 +0200
committerJo-Philipp Wich <jo@mein.io>2021-06-14 15:14:19 +0200
commitf6a03bff5bccdbf9165087bccbb35095903d05c6 (patch)
tree923de69a32d1a284829dfa721b851a186902e278 /include/package-ipkg.mk
parent677813c77678b80e99c4f97b433f428de26ca10f (diff)
downloadopenwrt-f6a03bff5bccdbf9165087bccbb35095903d05c6.tar.gz
openwrt-f6a03bff5bccdbf9165087bccbb35095903d05c6.tar.bz2
openwrt-f6a03bff5bccdbf9165087bccbb35095903d05c6.zip
build: prepend ABI suffixes with a dash if package name ends with digit
Ensure that ABI suffixes are separated with a dash from the package name if the name happens to end with a digit. This implementation detail got lost during the recent refactoring of the ABI_VERSION handling in buildroot. Ref: https://github.com/openwrt/packages/pull/14237#issuecomment-860473585 Fixes: c921650382 ("build: drop ABI version from metadata") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index b066e116f7..19f09c2311 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -99,7 +99,7 @@ _endef=endef
ifeq ($(DUMP),)
define BuildTarget/ipkg
- ABIV_$(1):=$(if $(filter-out kmod-%,$(1)),$(ABI_VERSION))
+ ABIV_$(1):=$(call FormatABISuffix,$(1),$(ABI_VERSION))
PDIR_$(1):=$(call FeedPackageDir,$(1))
IPKG_$(1):=$$(PDIR_$(1))/$(1)$$(ABIV_$(1))_$(VERSION)_$(PKGARCH).ipk
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg-$(PKGARCH)/$(1)