summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2024-02-21 13:16:35 -0800
committerPaul Spooren <mail@aparcar.org>2024-03-29 23:42:22 +0100
commitd08ff66fcd786848dcb911a7cb529066a9130343 (patch)
treed929ed8fcb23a0c616e2073a075a85f032e5e940 /include
parentfcdc629144983cf5e3f5509e35149096aa2701b3 (diff)
downloadopenwrt-d08ff66fcd786848dcb911a7cb529066a9130343.tar.gz
openwrt-d08ff66fcd786848dcb911a7cb529066a9130343.tar.bz2
openwrt-d08ff66fcd786848dcb911a7cb529066a9130343.zip
tools/meson: static host and both libraries
Host packages typically are statically linked to avoid rpath issues and to avoid libraries not being found as a result. With target packages, both libraries make the most sense as InstallDev typically installs both, giving packages flexibility. Default this behavior. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/meson.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/meson.mk b/include/meson.mk
index 65716746fe..2a20c2bd6b 100644
--- a/include/meson.mk
+++ b/include/meson.mk
@@ -100,6 +100,7 @@ define Host/Configure/Meson
$(call Meson, \
setup \
--native-file $(HOST_BUILD_DIR)/openwrt-native.txt \
+ -Ddefault_library=static \
$(MESON_HOST_ARGS) \
$(MESON_HOST_BUILD_DIR) \
$(MESON_HOST_BUILD_DIR)/.., \
@@ -126,6 +127,7 @@ define Build/Configure/Meson
--buildtype plain \
--native-file $(PKG_BUILD_DIR)/openwrt-native.txt \
--cross-file $(PKG_BUILD_DIR)/openwrt-cross.txt \
+ -Ddefault_library=both \
$(MESON_ARGS) \
$(MESON_BUILD_DIR) \
$(MESON_BUILD_DIR)/.., \